Question

[Solved] Yarn global command not working

I’m working with Yarn v0.16.1. If I understand correctly (according to the documentation), yarn global add <package> should be the equivalent of npm install -g <package>. However, when I run the example in the docs (with create-react-app), the command runs successfully but create-react-app is then not available from the command line. Here’s the output:

$ yarn global add create-react-app
$ yarn global v0.16.1
[1/4] 🔍  Resolving packages...
[2/4] 🚚  Fetching packages...
[3/4] 🔗  Linking dependencies...
[4/4] 📃  Building fresh packages...
success Installed [email protected]0.6.0 with binaries:
  - create-react-app
✨  Done in 3.22s.
$ create-react-app --help
-bash: create-react-app: command not found

Doing a global install with npm has the expected result, and everything works. What am I missing with yarn?

Enquirer: jaredsk

||

Solution #1:

You should add export PATH="$PATH:$(yarn global bin)" to your ~/.bash_profile or whatever you use. It would solve the issue.

Depending on how you installed it, Yarn’s global folder varies for some reason. You can follow this issue here.

Respondent: Kvartz

Solution #2:

Update Dec 2018

Just updating the path didn’t work for me. I had to also set the yarn prefix.

  • Ubuntu 18.04.1 LTS (bionic)
  • yarn 1.12.3
  • npm v3.5.2
  • node v8.10.0
  • zsh 5.4.2

Steps

  1. Confirm your global bin path

    yarn global bin
    

I got: /home/username/.yarn/bin

  1. set yarn prefix:

    make sure your yarn prefix is the parent directory of your bin directory. You can confirm by running

    yarn config get prefix
    

    when I ran this, my prefix was empty, so I set it:

    yarn config set prefix ~/.yarn
    
  2. add the following to ~/.bash_profile or ~/.bashrc

    export PATH="$PATH:`yarn global bin`"
    

    for zsh users, be sure to add this line to ~/.zshrc

  3. restart your shell or start a new one

    bash -l or zsh

Respondent: AndrewD

Solution #3:

In my case yarn global bin wasn’t working.

Try a brew reinstall yarn if that’s how you installed yarn

👍🏻

Respondent: Antoine

Solution #4:

Ran into this issue but on a Windows system. All I had to do was add the yarn global bin to the PATH variable.

setx path "%path%;c:usersYOURUSERNAMEappdatalocalyarnin"

Remember to change YOURUSERNAME to your account username.

You can check where your global bin is by running

yarn global bin

And please don’t forget to restart the CMD window that you’re working on.
Happy coding!

Respondent: Thapedict

Solution #5:

To reinstall run below.

brew install -g yarn

// Note:(updating homebrew) for Mac users.

brew reinstall yarn

// (if yarn is still not found)

Respondent: heyfranksmile

Solution #6:

On Ubuntu, I fixed by installing the package like this:

sudo yarn global add <package> --prefix /usr/local
Respondent: Florian Ludewig

Solution #7:

Here’s the process I used on Mac OSX El Capitan.

  1. Try to install yarn (I used the Curl command) if you have it already. This will bring up if its already installed and will give you the current directory where it exists.

Like this:

curl -o- -L https://yarnpkg.com/install.sh | bash

It will display something like this:

Installing Yarn!
> /Users/{Your Username}/.yarn already exists, possibly from a past Yarn install.
> Remove it (rm -rf /Users/{Your Username}/.yarn) and run this script again.

Do not remove it. Move on to step 2.

  1. Copy the directory listed above. Open your profile. I’m using zsh. So mine was ~/.zshrc. You can find yours and more info here.

  2. Copy the following (replacing your directory and username details as necessary, the one you got from the installation error message).

    alias yarn="/Users/{Your Username}/.yarn/bin/yarn"

  1. Try to run yarn version to check if its working. If it is, you should see a version number displayed in your terminal.

That’s it, and what worked for me.

Respondent: Tapha

Solution #8:

AndrewD gave a great answer, but for those on Windows it’s a bit different, especially step 3.

Please do not use the command setx as @Thapedict said.
It will remove all your previous paths you had and replace it with only the given directory.
If you want to use setx, I think there might be a flag to make it append the existing path variables, but I don’t know which one. Using only setx will not append to it.

I would just do System Properties > Advanced > Environment Variables > Edit Path > New > c:usersYOURUSERNAMEappdatalocalyarnin

to make sure you don’t remove your previous variables.

Respondent: Luddebror

Solution #9:

When switching from bash to zsh, I got the same error, it worked for me:

in your .zshrc 

# NVM Stuff
export NVM_DIR="$HOME/.nvm"
. "$(brew --prefix nvm)/nvm.sh"

# YVM Stuff
export YVM_DIR="$HOME/.yvm"
. "$(brew --prefix yvm)/yvm.sh"

As I understand it, my mistake arose due to the lack of access to version managers

Respondent: ex btrg

Solution #10:

For macOS, you just need one step,

export PATH=~/.yarn/bin:$PATH
Respondent: Harsh Patel

The answers/resolutions are collected from stackoverflow, are licensed under cc by-sa 2.5 , cc by-sa 3.0 and cc by-sa 4.0 .

Most Popular

To Top
India and Pakistan’s steroid-soaked rhetoric over Kashmir will come back to haunt them both clenbuterol australia bossier man pleads guilty for leadership role in anabolic steriod distribution conspiracy