[Solved] Windows- Can’t start Git: Probably the path to Git executable is not valid

Can't start Git: C:UsersCloudion PCAppDataLocalGitHubPortableGit_d93ee8917cfa9add886773e6be9ec08609a502b6ingit.exe Probably the path to Git executable is not valid.

I am getting the above message which is related to the git in android studio for far I am using android studio without any problem for last couple of months. now I am getting this all the time I type the code.


but now I cant find git.exe at the above. What happened? Does the location change?

Enquirer: Nabeel K


Solution #1:

finally I got it. the location of git.exe is changed from


Respondent: Nabeel K

Solution #2:

You need to set your Path to git executable to the folder where the git is installed on your system. Something like C:UsersProgramFiles….
enter image description here
The current path if you can see is not a good place to be. And every time you type a line of code Aandroi Studio seeks for the Git executable to trace the changes in the repo.

Respondent: Naman

Solution #3:

After installing GitHubDesktop:,
depending on your version, the location looks like:


In the Android Studio event console you can click on +Fix it+ link, right after Can't start Git: git.exe Probably the path to Git executable is not valid. message. This brings you to the setting window to enter the full path to the git.exe

Respondent: epox

Solution #4:

Type which git in your terminal/cmd (find out the git path)

which git

It will give you the original path, where it is installed. Then pass/set that path in your android studio and then click test button. It will be shown success.

My mistake was, previously I had a path like /usr/bin/git It doesn’t work.

which git

It gave the correct path. /usr/local/bin/git

FYI, I’m using Mac

Solution #5:

You first need to install git into your system if it is not already installed, check this link where you find download link and installing steps.

After successful installation you need to set the path of git.exe, So follow this:

File-> Setting-> Version Control -> Select Git From list-> in the
right panel add path of git.exe in front of Path to Git executable

It was C:Program FilesGitingit.exe in my case. click on test to check and then apply and ok.

Respondent: Suraj Vaishnav

The answers/resolutions are collected from stackoverflow, are licensed under cc by-sa 2.5 , cc by-sa 3.0 and cc by-sa 4.0 .

Most Popular

To Top
India and Pakistan’s steroid-soaked rhetoric over Kashmir will come back to haunt them both clenbuterol australia bossier man pleads guilty for leadership role in anabolic steriod distribution conspiracy