Question

[Solved] WAMP Server stays offline. MySQL service not starting “could not start the wampmysqld64 service – error 1067”

I have spent hours trying to get the server running (for the first time), trying many solutions posted online, but to no success.

First time install (Win 7 x64), light remains orage (server offline). If I look at service, the start/resume service remains green:

enter image description here

If I go in services and try start wampmysqld64 service I get this error message:

enter image description here

Here is the Event Viewer Application log (the WAMP mysql log is empty):

Error   11/09/2015 09:04:22 MySQL   100 None Aborting
Error   11/09/2015 09:04:22 MySQL   100 None Unknown/unsupported storage engine: InnoDB
Error   11/09/2015 09:04:22 MySQL   100 None Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
Error   11/09/2015 09:04:22 MySQL   100 None Plugin 'InnoDB' init function returned error.
Error   11/09/2015 09:04:22 MySQL   100 None InnoDB: Could not open or create the system tablespace. If you tried to add new data files to the system tablespace, and it failed here, you should now edit innodb_data_file_path in my.cnf back to what it was, and remove the new ibdata files InnoDB created in this failed attempt. InnoDB only wrote those files full of zeros, but did not yet use them in any way. But be careful: do not remove old data files which contain your precious data!
Error   11/09/2015 09:04:22 MySQL   100 None InnoDB: space header page consists of zero bytes in data file .ibdata1
Warning 11/09/2015 09:04:22 MySQL   100 None InnoDB: Doublewrite does not have page_no=0 of space: 0

I haven’t removed/deleted any files, but I did install WAMP server on my D drive (OS on C) due to space limitations).

Solution #1:

Installing WAMPServer on the D: drive is just fine.

Possibly somehow these files have been corrupted so try deleting them.

Stop WAMPServer

Delete these files, as this is an initial install they will not have any data in them and the restart of WAMPServer should cause MYSQL to re-create them.

wampinmysqlmysql5.6.17dataib_logfile0
wampinmysqlmysql5.6.17dataib_logfile1
wampinmysqlmysql5.6.17dataibdata1

Now for a little bug fix: Edit wampinmysqlmysql5.6.17my.ini
Find the section marker [wampmysqld] and change it to [wampmysqld64]

Save my.ini

Restart WAMPServer

Also if you are a little short of memory adding this parameter to the my.ini file inside the [wampmysqld64] will reduce the MYSQL memory requirement. Later versions of MYSQL seem to use a hugh amounts of memory ( half a gig ) lots of which is the table_definition_cache for MYISAM files, this will reduce it to something sensible and not effect your use of MYISAM files.

[wampmysqld64]
table_definition_cache = 600
Respondent: RiggsFolly
Solution #2:

In my case I just had to: edit wampinmysqlmysql5.6.17my.ini and find the section [wampmysqld] and change it to [wampmysqld64].

Then I restarted mysql and it worked!

Respondent: Hideki Nakamura
Solution #3:

For me, I realised that I had another MySQL program (from Oracle) installed that was causing a common port-use conflict. Uninstall/disable MySQL server/workbench and other MySQL programs then restart WAMP. This might solve the problem, it worked for me.

I also uninstalled and deleted an old version of WAMP before installing the latest version.

Respondent: marvatron
Solution #4:

WAMP is a less stable platform. I would suggest XAMPP over WAMP.
It is light compared to wamp-server and much stable than WAMP.

Benefits –

XAMPP is more powerful and resource taking than WAMP.
WAMP provides support for MySQL and PHP.
XAMPP provides support for MYSQL, PHP and PERL

XAMPP also has SSL feature while WAMP doesn’t.
If your applications need to deal with native web apps only, Go for WAMP. If you need advanced features as stated above, go for XAMPP.

As of priority, you cant run both together with default installation as XAMPP gets a higher priority and it takes up ports. So WAMP can’t be run in parallel with XAMPP.

Respondent: Srinath Kamath
Solution #5:
  1. If mysql service is not starting open my.ini file located at C:wampinmysqlmysql[version]my.ini
  2. Change port number to 3305 at 3 location:

Here:

#password   = your_password
port        = 3305
socket      = /tmp/mysql.sock

Here:

# The MySQL server
[wampmysqld]
port        = 3305

And here:

[mysqld]
port=3305
  1. Now go to C:wampappsphpmyadmin[version], find config.inc.php and change this line:
$cfg['Servers'][$i]['port'] = '3306';

to this:

$cfg['Servers'][$i]['port'] = '3305';

(3305 being the port you selected previously).

Those steps should get your MySQL running.

Respondent: Saish Shinde
The answers/resolutions are collected from stackoverflow, are licensed under cc by-sa 2.5 , cc by-sa 3.0 and cc by-sa 4.0 .

Most Popular

To Top
India and Pakistan’s steroid-soaked rhetoric over Kashmir will come back to haunt them both clenbuterol australia bossier man pleads guilty for leadership role in anabolic steriod distribution conspiracy