Question

[Solved] Unable to start Genymotion virtual device, incompatible CPU

The first time I ran Genymotion virtual device, it had worked. But when I tried running it today, I got this error message

enter image description here

What may have changed from the last time I used it? Will be grateful for any solutions that I can get. Thanks.

My Device Info:
Dell XPS L502X
Sandy Bridge motherboard
Intel Core i5-2410M @2.30 GHz
Windows 7 Professional 64-bit

Enquirer: saurjk

||

Solution #1:

You need to turn virtualization on.

  1. Reboot the notebook.
  2. Instantly press F10 to enter BIOS settings (or F2 depending on your PC)
  3. Check the settings and look for Intel Virtualization Technology (Aliases: Intel VT-x).
  4. Turn it on then save and exit. You could use F10 to save and exit.

This will enable you to use virtualization and enable VirtualBox. Therefore your emulator will hopefully work.

Respondent: Coderji

Solution #2:

I’ve solved my problem just turning off the Hyper-V on Windows Features.

Respondent: Douglas Franco

Solution #3:

Another way to receive this message is because you are running another application that use VT-x like the Android Emulator from Android Studio. If you open Virtualbox and try to start the VM you will get this error message. Solution: Close the other emulator and try again.

Respondent: Juan Saravia

Solution #4:

For me the following worked:

Disable/uncheck “Enable VT-x/AMD-v” in the virtual device’s Settings-> System -> Acceleration

Respondent: saurjk

Solution #5:

Execute the following command in cmd opened as administrator to disable hyper-v and then reboot the machine:

bcdedit /set hypervisorlaunchtype off

I don’t know why disabling hyper-v from system preferences doesn’t work for me, only the command works for me. Also I had to close Docker first to execute the command.

Respondent: pableiros

Solution #6:

Solution for windows 10: Control Panel ? Programs ? Turn Windows components on or off.
Uncheck the Hyper-V option and click OK.

Respondent: lolamore

Solution #7:

I’ve also seen this exact same error dialog (for the first time ever) today after upgrading to the latest versions of both VirtualBox and GenyMotion. Nothing else on my system has changed. It’s not the best answer in the world, but after trying a few other suggestions I came across, I found that simply cancelling the dialog and restarting the virtual Genymotion device (either via Android Studio or via the Genymotion console) resolved the problem.

Respondent: Groovee60

Solution #8:

Fix it in Virtualbox directly

  1. Open VirtualBox
  2. If you find a similarly named device “Inaccessible” or any other state than “switched off”, stop it or remove it.
  3. Start the device from Genymotion

  1. Feel Happy 🙂
Respondent: Dheeraj Bhaskar

Solution #9:

i just decreased the amount of base memory used by the machine in virtualbox manager settings > System > Base Memory and it worked.

Respondent: Braveheart-EGY

Solution #10:

In VirtualBox settings > System disable I/O, EFI, UTC and AMD-V.
And Settings > Network > Promiscuous Mode modify in all.

Respondent: Ivan

Solution #11:

I’ve seen this exact same error dialog on the first install. I changed my BIOS settings and it worked but after a month the same error occurred.

My solution:

  1. Open VirtualBox Manager
  2. Settings > Network > Promiscuous Mode
  3. Change from “deny” to “allow”
Respondent: Mete

Solution #12:

I had to deactivate ‘Memory Integrity‘ of Windows 10 (1803) ‘Core Isolation’ Feature of Windows Defender. It is deactivated by default, and for some odd reason I had forgotten I had switched it on recently.

I also checked that in VirtualBox -> Your virtual machine -> Settings -> System -> Acceleration -> ‘Enable VT-x/AMD-v’ and ‘Enable nested paging’ are activated, Hyper-V is not installed and virtualization is turned on in BIOS.

There is an explaining article on HowToGeek explaining that aformentioned Memory integrity feature:
https://www.howtogeek.com/357757/what-are-core-isolation-and-memory-integrity-in-windows-10/

Respondent: hennzen

Solution #13:

I have solved this issue not just by enabling VT-x but also by enabling VT-d (Virtualization Technology for directed I/O) in BIOS

Respondent: Kerisnarendra

Solution #14:

I fixed it in VirtualBox:
Setting > System > Disable checkbox “Nested Paging”

Respondent: ?????? ??????

Solution #15:

One more correct answer is that recent versions of Genymotion support only 64bit CPU and that will cause the same error.

Respondent: Jehy

Solution #16:

For me the solution was to close another emulator which was open.

Respondent: dynamo

Solution #17:

None of the solution worked for me. This is what solved the issue:

  1. Turn on Hyper-V in Windows Features.
  2. Restart PC.
  3. Turn off Hyper-V in Windows Features.
  4. Restart PC.

Boom!

Respondent: Paras Sidhu

Solution #18:

in ubuntu

1-Reboot the notebook.

2-enter BIOS (press F10 or F2 )

3-Check enable Intel Virtualization Technology and save and exit.

Respondent: Netwons

Solution #19:

I Had The Same Problem And I Solve It By Turning Off The Hyper -v In Windows Programs And Features. Now I Can Start Any Virtual Device From Both Android Studio And Genymotion.

Respondent: J S Afridi

The answers/resolutions are collected from stackoverflow, are licensed under cc by-sa 2.5 , cc by-sa 3.0 and cc by-sa 4.0 .

Most Popular

To Top
India and Pakistan’s steroid-soaked rhetoric over Kashmir will come back to haunt them both clenbuterol australia bossier man pleads guilty for leadership role in anabolic steriod distribution conspiracy