Question

[Solved] Run Button is Disabled in Android Studio

I can’t click the run button. Does anyone know how to fix it?

Disabled Run Button

Enquirer: wiz

||

Solution #1:

Click Run on the menu and then Edit Configurations… then click on Android Application on the left and click the + button. Choose Android Application from the pop-up menu. Then pick the module (its normally app or something like that). Then click apply and ok.

If you have more errors after that, try to re-import the project in Android Studio.

Respondent: Thanos

Solution #2:

When creating the Run Configuration, the dropdown for Module had only <no module> for me. Invoking menu File -> Sync Project with Gradle Files added app to the dropdown for Module. Then the Run button became enabled.

Respondent: Big Pumpkin

Solution #3:

Just click the dropdown button on left side of RUN button (in your image the dropdown which is in red box) select ‘app’ option from that and RUN button will be enabled.

Please refer below screenshot.

enter image description here

Respondent: Nikunj Acharya

Solution #4:

The above answer didn’t work for me, instead closing the project and restaring the AS IDE worked for me.

Respondent: Driss Bounouar

Solution #5:

just to go File -> Sync Project with Gradle files then it solves problem.

Respondent: Sai Gopi Me

Solution #6:

for flutter project, if the run button is disabled then you have to

tools>> flutter>> flutter packages get >>enter your flutter sdk path >>finish

This should solve your problem…

Respondent: Pruthwiraj Nayak

Solution #7:

It was quite silly for me, I just opened the Run > Run Configurations window
everything seemed to be fine there, I didn’t change anything, when I closed the window the button was enabled.

Respondent: Dan Levin

Solution #8:

If you have changed jdk version then go to File->Project Structure->Select SDK Location from left bar->update JDK Location in editbar in right bar.

Respondent: shripal

Solution #9:

If your IDE is in power save mode, then the run button etc. are also disabled.

You can verify this via the file -> power save mode, make sure it is disabled.

Disable power save mode to enable the run button

Solution #10:

Above answer didn’t work for me, just do click File -> Invalidate/cache -> Invalidate and Restart.

Respondent: Sumit

Solution #11:

You have to reconfigure the FlutterSDK path in Android Studio: Go to Setting -> Language & Frameworks -> Flutter and set the path to Flutter SDK

Solution #12:

I just clicked on the debug icon and it started working.

enter image description here

Solution #13:

if you’re importing an eclipse project to android studio, you’ll also encounter the same issue as above. Double Check if grade>app has
apply plugin: ‘com.android.application’ on the top as sometimes android studio imports it as a library.

Respondent: the_legend_27

Solution #14:

  • Select the project view in the android studio.
  • Remove all gradle folders.
  • Restart the android studio.

This will work.

The issue is happening since the gradle was configured for an android studio in another machine and the files pushed on the git and are using in your studio.

After removing these gradle files and restarting the studio, the studio will generate gradle files for your system. This will solve the issue.

Respondent: Akhil MG

Solution #15:

If you are trying to run the Flutter Project in Android Studio, and the run button is disabled then here is the solution

enter image description here

Click on add configuration

enter image description here

and select Flutter and then select the main class in dataentrypoint

Respondent: Umer Waqas

Solution #16:

I’m using Linux where I had a symlink in my home folder pointing to a folder containing the Android Studio projects. Loading a project using the symlink failed, loading a project from the folder where the symlink is pointing to worked!

Respondent: Jasper de Vries

Solution #17:

My solution was to go to that multiselect button, then “Edit Configurations” -> Go to “+” and select the module (in this case it would be an app if you do not have a multiproject -> then apply and OK

Respondent: Carlos Valdez

Solution #18:

I opened the wrong folder…. Verify is your root folder in Android studio has the build.gradle file.

Respondent: Richard Lindhout

Solution #19:

Build->Clean Project

make the run button enable again in my case

Respondent: Linh

Solution #20:

Happened to me twice, and then I figured out it happened after I upgraded my flutter version. When I opened (flutter SDK path) in (flutter) tab in (system preferences) I found it empty.

Solution was to point out to flutter directory on my disk from (flutter SDK path) in (flutter) tab in (Android studio preferences).

Respondent: Khaled Mahmoud

Solution #21:

For me increasing the version of compile SDK to latest solved my issue, Go to

build.gradle(app-level)

compileSdkVersion 30

Because My Emulator is Api-level 30

Respondent: Devinder Jhinjer

The answers/resolutions are collected from stackoverflow, are licensed under cc by-sa 2.5 , cc by-sa 3.0 and cc by-sa 4.0 .

Most Popular

To Top
India and Pakistan’s steroid-soaked rhetoric over Kashmir will come back to haunt them both clenbuterol australia bossier man pleads guilty for leadership role in anabolic steriod distribution conspiracy