Question

[Solved] react-native :app:installDebug FAILED

Install APK debug to my device failed.

jianglinghuadeMacBook-Pro:hello jianglinghua$ react-native run-android
JS server already running.
Building and installing the app on the device (cd android && ./gradlew installDebug...
WARNING [Project: :app] Current NDK support is deprecated.  Alternative will be provided in the future.
:app:preBuild UP-TO-DATE
......
:app:assembleDebug UP-TO-DATE
:app:installDebug
Installing APK 'app-debug.apk' on 'MI NOTE LTE - 6.0.1'
Unable to install /Users/jianglinghua/Desktop/hello/android/app/build/outputs/apk/app-debug.apk
com.android.ddmlib.InstallException: Failed to establish session
    at com.android.ddmlib.Device.installPackages(Device.java:894)
    ........
    at org.gradle.wrapper.GradleWrapperMain.main(GradleWrapperMain.java:61)
:app:installDebug FAILED

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':app:installDebug'.
> com.android.builder.testing.api.DeviceException: com.android.ddmlib.InstallException: Failed to establish session

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

BUILD FAILED

Total time: 13.945 secs

Could not install the app on the device, read the error above for details.
Make sure you have an Android emulator running or a device connected and have
set up your Android development environment:
https://facebook.github.io/react-native/docs/android-setup.html

I look at my devices

jianglinghuadeMacBook-Pro:hello jianglinghua$ adb devices
List of devices attached
98333978    device
Enquirer: ???

||

Solution #1:

Since you are using Mi phone which has MIUI

try this

go to Developer options, scroll down to find ‘Turn on MIUI optimization’ & disable it. Your Phone will be rebooted

check now


If you are using any other android phone, which has a custom skin/UI on top of android OS, then try disabling the optimization provided by that UI and check.
(usually you can find that in ‘Developer options’)

Respondent: anmolakhilesh

Solution #2:

In my case, I have set up a new app but I was getting errors, tried many possible ways and answers from github and stackoverflow.
nothing worked

error
enter image description here
The solution for me was .. check if you already have an app with the same name is installed in android..

Delete old apps and run react-native run-android

Worked for me.

Respondent: Jahanzeb Nawaz

Solution #3:

I had this issue. Mine worked on the emulator well but it didn’t work on the device and the error was

app:installDebug FAILED.

If you have a different app with the same name (or package name) on the device:
Rename the app or delete it from your device.

Respondent: Mohsen Biglari

Solution #4:

on my android device, the problem was about the previous build versions of the application that I had installed on my phone before.
the following steps solved my problem:

  1. removing any previous build of the application, including debugging version and signed apk version

  2. on the root directory of your project, run (on windows):

    cd android

    .gradlew clean

    cd ..

    npm cache clean --force

  3. reboot your android device

hope this help you too.

Respondent: Mahdieh Shavandi

Solution #5:

This works for me

  1. Uninstall the app from your phone
  2. cd android
  3. gradlew clean
  4. cd ..
  5. react-native run-android
Respondent: Hammad Hassan

Solution #6:

I got the same problem and did some research. This problem happens a lot on Chinese android phones.

It was solved by change the gradle version to 1.2.3 in file android/build.gradle line 8

classpath 'com.android.tools.build:gradle:1.2.3'
Respondent: Dubbo

Solution #7:

  1. Go to android/build.gradle, change

    classpath 'com.android.tools.build:gradle:2.2.3'
    to

    classpath 'com.android.tools.build:gradle:1.2.3'

  2. Then, go to
    android/gradle/wrapper/gradle-wrapper.properties,
    change distributionURL to https://services.gradle.org/distributions/gradle-2.2-all.zip

  3. Run again.

Respondent: Ikhwanul Muslimin

Solution #8:

In my case (with React Native), my Android phone was unrecognized by my PC where I was running the server, which can be seen by the message:

* What went wrong:
Execution failed for task ':app:installDebug'.
> com.android.builder.testing.api.DeviceException: No online devices found.

If that is the case, as highlighted in ADB Android Device Unauthorized, make sure that in Developer Options on your phone USB Debugging is set to true, and enter the following commands in terminal or cmd to restart the Android server.

adb kill-server
adb start-server

And adb devices should list your phone as device instead of unauthorized

Respondent: Larry

Solution #9:

If none of the above solutions works then try the following steps to cold boot the emulator

open AVD manager -> Edit device -> Show Advanced Settings -> Boot option -> select Cold Boot instead of Quick boot.

Respondent: CodeZombie

Solution #10:

In my case, I had the app downloaded from PlayStore and I was trying to debug the APK with the same name. I just uninstalled the app and debugged successfully.

Respondent: CPJ

Solution #11:

I also got troubles with app using gradle 2.14, though with gradle 4 it’s ok. By using –deviceID flag app instals without any issue.

react-native run-android --deviceId=mydeviceid
Respondent: Nerius Jok

Solution #12:

I had this problem and I removed the apk file from my android device/emulator and then run react-native run-android and run successfuly .

Respondent: hamed98

Solution #13:

On MIUI , inside developer option by default “Install via USB” is disabled.Enable it and than it allows installing app via usb.

Respondent: Sharthak

Solution #14:

  1. Delete the app from the device.
  2. Edit the file (YourAppName -> android -> app -> build.gradle) enter the line below on the defaultConfig field

multiDexEnabled true

defaultConfig {
    multiDexEnabled true //this is the line you need to enter
    applicationId "xxxxxx"
    minSdkVersion xxxxx
    targetSdkVersion xxxxx
    versionCode xx
    versionName "xx"
}
  1. rebuild the app
Respondent: Moh .S

Solution #15:

I couldn’t get it to work with a hardware device. I kept getting the same error, but…

For your emulator you have to choose the IntelX86 Atom System image. Then ADB will connect to your emulator and it will properly install the installDebug.apk.

This is what I had to do.

Also look at this tutorial. It helped me immensely.

https://www.youtube.com/watch?v=cnqyUnASuk8

Respondent: Miguel Coder

Solution #16:

Previously, I had installed npm and then installed yarn, and that is when I started to have problems compiling, even when creating new projects with react-native init . Uninstalling yarn, I was able to create and compile.

Respondent: JxDarkAngel

Solution #17:

In my case, I did not have enough space on my device to install the app,
so I cleared up some space and tried again

Respondent: sumukha hegde

Solution #18:

open avd manager click on the arrow next to the pencil icon and wipe data works for me…

Respondent: Umair Raees

Solution #19:

For me, restarting my phone did the trick.

Respondent: Daniel Sun Yang

Solution #20:

I had the same issue with wrong AVD settings.
Probably, “Target Android 6.0” was wrong choice.

Next settings were changed to fix “:app:installDebug FAILED” issue:
System Image: Marshmallow , API 23, ABI x86, Target Google API.

see the detail information about this here:
RN Android Setup

Respondent: mikowiec

Solution #21:

Just lock and unlock the android solved my issue then

adb reverse tcp:8081 tcp:8081
Respondent: Zeeshan Ansari

Solution #22:

I got the same error but the issue was I did on the USB Debugging after unable this is working for me.

Thanks

enter image description here

Respondent: Parveen Chauhan

Solution #23:

Just go to the Developer option in your phone and disable and again enable usb debugging. It will work.

Solution #24:

In my case, I manually delete the app-debug.apk file and run it again.

Solution #25:

As you add more modules to Android, there is an incredible demand placed on the Android build system, and the default memory settings will not work. To avoid OutOfMemory errors during Android builds, you should uncomment the alternate Gradle memory setting present in /android/gradle.properties:

# Specifies the JVM arguments used for the daemon process.
# The setting is particularly useful for tweaking memory settings.
# Default value: -Xmx10248m -XX:MaxPermSize=256m
org.gradle.jvmargs=-Xmx2048m -XX:MaxPermSize=512m -XX:+HeapDumpOnOutOfMemoryError -Dfile.encoding=UTF-8
Respondent: Justin.Mathew

Solution #26:

In my case, It is problem of permissions or we can say that setting problem present inside developer options. I am using MI Note 10.To avoid this issue,permit some setting such as common one developer option and USB debugging as well as Install via USB,USB debugging(Security settings), Verify apps over USB.

Respondent: Rutuja Kherde

Solution #27:

Step 1: Close Android Emulator.

Step 2: Open Android Virtual Device Manager and wipe data by the following image:
enter image description here

Step 3: Open your terminal and type

cd android
.gradlew clean
cd ..
npm cache clean --force

Step 4: In terminal, run:

yarn run android

Note: If you are using yarn, just run:

yarn cache clean
Respondent: Hai Dinh

The answers/resolutions are collected from stackoverflow, are licensed under cc by-sa 2.5 , cc by-sa 3.0 and cc by-sa 4.0 .

Most Popular

To Top
India and Pakistan’s steroid-soaked rhetoric over Kashmir will come back to haunt them both clenbuterol australia bossier man pleads guilty for leadership role in anabolic steriod distribution conspiracy