Question

[Solved] Python: Pandas pd.read_excel giving ImportError: Install xlrd >= 0.9.0 for Excel support

I am trying to read a .xlsx with pandas, but get the follwing error:

data = pd.read_excel(low_memory=False, io="DataAnalysis1/temp1.xlsx").fillna(value=0) 

Traceback (most recent call last):
  File "/Users/Vineeth/PycharmProjects/DataAnalysis1/try1.py", line 9, in <module>
    data = pd.read_excel(low_memory=False, io="DataAnalysis1/temp1.xlsx").fillna(value=0)
  File "/Users/Vineeth/venv/lib/python2.7/site-packages/pandas/util/_decorators.py", line 118, in wrapper
    return func(*args, **kwargs)
  File "/Users/Vineeth/venv/lib/python2.7/site-packages/pandas/io/excel.py", line 230, in read_excel
    io = ExcelFile(io, engine=engine)
  File "/Users/Vineeth/venv/lib/python2.7/site-packages/pandas/io/excel.py", line 263, in __init__
    raise ImportError(err_msg)
ImportError: Install xlrd >= 0.9.0 for Excel support

I’ve also tried

data = pd.read_excel("DataAnalysis1/temp1.xlsx", low_memory=False).fillna(value=0)

And I Still get the same error.

Background: I’m trying to extract an excel file with multiple worksheets as a dict of data frames.I installed xlrd version 0.9.0 and the latest version(1.1.0) but I still get the same error. Thanks!

Solution #1:

As @COLDSPEED so eloquently pointed out the error explicitly tells you to install xlrd.

pip install xlrd

And you will be good to go.

Respondent: Grr

Solution #2:

Either use:

pip install xlrd

And if you are using conda, use

conda install -c anaconda xlrd

That’s it. good luck.

Respondent: E. Erfan

Solution #3:

Since December 2020 xlrd no longer supports xlsx-Files as explained in the official changelog. You can use openpyxl instead:

pip install openpyxl

And in your python-file:

import pandas as pd
pd.read_excel('path/to/file.xlsx', engine='openpyxl')
Respondent: tech-prism

Solution #4:

I was getting an error

“ImportError: Install xlrd >= 1.0.0 for Excel support”

on Pycharm for below code

import pandas as pd
df2 = pd.read_excel("data.xlsx")
print(df2.head(3))
print(df2.tail(3))

Solution : pip install xlrd

It resolved error after using this.
Also no need to use “import xlrd

Respondent: Omkar

Solution #5:

This works for me:
For Python 3

pip3 install xlrd –user

For Python2

pip install xlrd –user

Respondent: Minhaj Javed

Solution #6:

This happened to me after I ran a script with cProfile a la python3 -m cProfile script.py even though xlrd was already installed and had never thrown this error before. it persisted even under python3 script.py. (Granted, I agree this wasn’t what happened to OP, given the obvious import error)

However, for cases like mine, the following fixed the issue, despite being told “requirement already met” in every case.

pip install --upgrade pandas
pip install --upgrade xlrd

Pretty confounding stuff; not sure if cProfile was the cause or just a coincidence

The following should work, assuming your pip install operated on python2.

python3 -m pip install xlrd
Respondent: 3pitt

Solution #7:

I don’t know if this will be helpful for someone, but I had the same problem.
I wrote pip install xlrd in the anaconda prompt while in the specific environment and it said it was installed, but when I looked at the installed packages it wasn’t there.
What solved the problem was “moving” (I don’t know the terminology for it) into the Scripts folder of the specific environment and do the pip install xlrd there.
Hope this is useful for someone 😀

Solution #8:

Was getting the error while I was using jupyter.

ModuleNotFoundError: No module named 'xlrd'
...
ImportError: Install xlrd >= 0.9.0 for Excel support

it was resolved for me after using.

!pip install xlrd
Respondent: Santosh sanwal

Solution #9:

I encountered same problem and took 2 hours to figure it out.

  1. pip install xlrd (latest)
  2. pip install pandas (latest)
  3. Go to C:Python27Libsite-packages and check for xlrd folder (if there are 2 of them) delete the old version
  4. open a new terminal and use pandas to read excel. It should work.
Respondent: Vivek Sh

Solution #10:

I had the same problem and none of the above answers worked. If you go into the settings (CTRL + ALT + s) and search for project interpreter you will see all of the installed packages. Click the + button at the top right and search for xlrd, then click install package at the bottom left.

I had already done the “pip install xlrd” command from the file location of my python.exe before this, so you may need to do that as well. (you can find the file location by searching it in windows search bar and right click -> open file location, then type cmd into the file explorer address bar)

Respondent: Joe Giusti

Solution #11:

First of all you need to install xlrd & pandas packages. Then try below code.

import xlrd
import pandas as pd

xl = pd.ExcelFile("fileName.xlsx")
print(xl.parse(xl.sheet_names[0]))
Respondent: reza.cse08

Solution #12:

You need to install the “xlrd” lib

For Linux (Ubuntu and Derivates):

Installing via pip:
python -m pip install –user xlrd

Install system-wide via a Linux package manager:
*sudo apt-get install python-xlrd

Windows:

Installing via pip:
*pip install xlrd

Download the files:
https://pypi.org/project/xlrd/

Respondent: nilsoviani

Solution #13:

Another possibility, is the machine has an older version of xlrd installed separately, and it’s not in the “..:Python27Scripts..” folder.

In another word, there are 2 different versions of xlrd in the machine.

enter image description here

when you check the version below, it reads the one not in the “..:Python27Scripts..” folder, no matter how updated you done with pip.

print xlrd.__version__

Delete the whole redundant sub-folder, and it works. (in addition to xlrd, I had another library encountered the same)

Respondent: Mark K

Solution #14:

I encountered a similar issue trying to use xlrd in jupyter notebook. I notice you are using a virtual environment and that was the key to my issue as well. I had xlrd installed in my venv, but I had not properly installed a kernel for that virtual environment in my notebook.

To get it to work, I created my virtual environment and activated it.

Then… pip install ipykernel

And then… ipython kernel install --user --name=myproject

Finally, start jupyter notebooks and when you create a new notebook, select the name you created (in this example, ‘myproject’)

Hope that helps.

Respondent: Lennis Herburger

Solution #15:

Please make sure your python or python3 can see xlrd installation. I had a situation where python3.5 and python3.7 were installed in two different locations. While xlrd was installed with python3.5, I was using python3 (from python3.7 dir) to run my script and got the same error reported above. When I used the correct python (viz. python3.5 dir) to run my script, I was able to read the excel spread sheet without a problem.

Respondent: C K

The answers/resolutions are collected from stackoverflow, are licensed under cc by-sa 2.5 , cc by-sa 3.0 and cc by-sa 4.0 .

Most Popular

To Top
India and Pakistan’s steroid-soaked rhetoric over Kashmir will come back to haunt them both clenbuterol australia bossier man pleads guilty for leadership role in anabolic steriod distribution conspiracy