Question

[Solved] Plugin with id ‘com.google.gms.google-services’ not found

I have followed this link to integrate ads in my app. But it shows this error:

error image

This is my build.gradle:

apply plugin: 'com.android.application'
apply plugin: 'com.google.gms.google-services'
android {
compileSdkVersion 24
buildToolsVersion "24.0.2"





defaultConfig {
    applicationId "com.example.personal.numbermania"
    minSdkVersion 10
    targetSdkVersion 24
    versionCode 1
    versionName "1.0"
}
buildTypes {
    debug
            {
                debuggable true
            }
    release {
        minifyEnabled false
        proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
    }
}


dependencies {
    compile fileTree(include: ['*.jar'], dir: 'libs')
    testCompile 'junit:junit:4.12'
    compile 'com.android.support:appcompat-v7:24.2.1'
    compile 'com.android.support:design:24.2.1'
    compile 'com.google.firebase:firebase-ads:9.6.0'

}

}

ads are not showing up in real device.please help me
This is my error after i updated classpath
error

Enquirer: Lakshmi

||

Solution #1:

Had the same problem.

Fixed by adding the dependency

classpath 'com.google.gms:google-services:3.0.0'

to the root build.gradle.

https://firebase.google.com/docs/android/setup#manually_add_firebase

Respondent: Vasily Kabunov

Solution #2:

Add classpath com.google.gms:google-services:3.0.0 dependencies at project level build.gradle

Refer the sample block from project level build.gradle

buildscript {
    repositories {
        jcenter()
    }
    dependencies {

        classpath 'com.android.tools.build:gradle:2.3.3'
        classpath 'com.google.gms:google-services:3.0.0'

        // NOTE: Do not place your application dependencies here; they belong
        // in the individual module build.gradle files
    }
}
Respondent: eranda.del

Solution #3:

You can find the correct dependencies here apply changes to app.gradle and project.gradle and tell me about this, greetings!


Your apply plugin: ‘com.google.gms.google-services’ in app.gradle looks like this:

apply plugin: 'com.android.application'

android {
    compileSdkVersion 24
    buildToolsVersion "24.0.2"

    defaultConfig {
        applicationId "com.example.personal.numbermania"
        minSdkVersion 10
        targetSdkVersion 24
        versionCode 1
        versionName "1.0"

        multiDexEnabled true
    }

    dexOptions {
        incremental true
        javaMaxHeapSize "4g" //Here stablished how many cores you want to use your android studi 4g = 4 cores
    }

    buildTypes {
        debug
                {
                    debuggable true
                }
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }
}

dependencies {
        compile fileTree(include: ['*.jar'], dir: 'libs')
        testCompile 'junit:junit:4.12'
        compile 'com.android.support:appcompat-v7:24.2.1'
        compile 'com.android.support:design:24.2.1'
        compile 'com.google.firebase:firebase-ads:9.6.1'
        compile 'com.google.firebase:firebase-core:9.6.1'
        compile 'com.google.android.gms:play-services:9.6.1'
}

apply plugin: 'com.google.gms.google-services'

Add classpath to the project’s gradle:

classpath 'com.google.gms:google-services:3.0.0'

Google play services library on SDK Manager:

enter image description here

Solution #4:

Had the same problem.

adding this to my dependency didn’t solve

classpath ‘com.google.gms:google-services:3.0.0’

Adding this solved for me

classpath ‘com.google.gms:google-services:+’

to the root build.gradle.

Solution #5:

simply add “classpath ‘com.google.gms:google-services:3.0.0′” to android/build.gradle to look like this

buildscript {
    repositories {
        maven {
            url "https://maven.google.com"
        }
        jcenter()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:3.0.1'
        classpath 'com.google.gms:google-services:3.0.0'

       // NOTE: Do not place your application dependencies here; they belong
       // in the individual module build.gradle files

    }
}

and also add “apply plugin: ‘com.google.gms.google-services'” to the end of file in android/app/build.gradle to look like this

apply plugin: 'com.google.gms.google-services'

Solution #6:

Go To Setting > Android SDK > SDK Tools > Google Play Services

enter image description here

Respondent: Keshav Gera

Solution #7:

In build.gradle(Module:app) add this code

dependencies {
    ……..
    compile 'com.google.android.gms:play-services:10.0.1’
    ……  
}

If you still have a problem after that, then add this code in build.gradle(Module:app)

defaultConfig {
    ….
    …...
    multiDexEnabled true
}


dependencies {
    …..
    compile 'com.google.android.gms:play-services:10.0.1'
    compile 'com.android.support:multidex:1.0.1'
}

Solution #8:

I changed google-services classpath version from 4.2.0 to 3.0.0

classpath 'com.google.gms:google-services:3.0.0'

Then rebuild the project, Then strangely it suggested me to add firebase core to the project.

Then I added firebase core on the app(module)

implementation 'com.google.firebase:firebase-messaging:16.0.8'

Then the error disappeared magically.

Solution #9:

In the app build.gradle dependency, you must add the following code

classpath 'com.google.gms:google-services:$last_version'

And then please check the Google Play Service SDK tools installing status.

Respondent: GoldCat

Solution #10:

On upgrading to Android Studio 4.2.1, I was prompted to set dependency:

classpath 'com.google.gms:google-services:4.3.7'

However, this caused “Plugin with id ‘com.google.gms.google-services’ not found”.
Leaving it as follows fixed the problem:

classpath 'com.google.gms:google-services:4.3.5'
Respondent: Edmund Johnson

Solution #11:

apply plugin: 'com.google.gms.google-services'

add above line at the bottom of your app gradle.build.

Solution #12:

I’m not sure about you, but I spent about 30 minutes troubleshooting the same issue here, until I realized that the line for app/build.gradle is:

apply plugin: 'com.google.gms.google-services'

and not:

apply plugin: 'com.google.gms:google-services'

Eg: I had copied that line from a tutorial, but when specifying the apply plugin namespace, no colon (:) is required. It’s, in fact, a dot. (.).

Hey… it’s easy to miss.

Respondent: James Perih

Solution #13:

In project’s build.gradle add the following

classpath 'com.google.gms:google-services:4.3.3'
Respondent: Shahzeb Mehdi

Solution #14:

Ended up on this thread while trying to integrate Firebase with a Flutter application. So, in case you are facing the same problem in Flutter, below steps solved the issue for me.

Disclaimer: first steps are the same as described in the documentation
and every answer/tutorial found online. I am just mentioning them on a
high level for the sake of keeping my answer consistent.

The actual step that is different and solved the issue is the last
one
.

  1. Add google-services.json in your flutter_app/android/app directory.
  2. On android/build.gradle add:
repositories {
    google()
    jcenter()
    maven {
        url "https://maven.google.com"
    }
}

dependencies {
        classpath 'com.android.tools.build:gradle:3.5.0'
        classpath 'com.google.gms:google-services:4.3.4'
        classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:$kotlin_version"
    }

allprojects {
    repositories {
        google()
        jcenter()
        maven {
            url "https://maven.google.com"
        }
    }
}
  1. On android/app/build.gradle add:
apply plugin: 'com.android.application'
apply plugin: 'kotlin-android'
apply from: "$flutterRoot/packages/flutter_tools/gradle/flutter.gradle"
apply plugin: 'com.google.gms.google-services'
  1. On android/app/build.gradle add also the following:
dependencies {
    implementation "org.jetbrains.kotlin:kotlin-stdlib-jdk7:$kotlin_version"

    implementation platform('com.google.firebase:firebase-bom:26.3.0')
    implementation 'com.google.firebase:firebase-analytics'
    implementation 'com.google.firebase:firebase-messaging'

    testImplementation 'junit:junit:4.+'
    androidTestImplementation 'androidx.test.ext:junit:1.1.2'
    androidTestImplementation 'androidx.test.espresso:espresso-core:3.3.0'
}

You can find a working demo for this here https://gitlab.com/ecocupaegean/ecocupaegean/-/tree/master/, in order to run the app you just need to add your own google-services.json, and specify an API KEY for google maps geolocation API.

Solution #15:

I am a remove/reinstall guy, so I disconnected from Firebase and reinstalled Firebase from console.

Respondent: doguzkaan

The answers/resolutions are collected from stackoverflow, are licensed under cc by-sa 2.5 , cc by-sa 3.0 and cc by-sa 4.0 .

Most Popular

To Top
India and Pakistan’s steroid-soaked rhetoric over Kashmir will come back to haunt them both clenbuterol australia bossier man pleads guilty for leadership role in anabolic steriod distribution conspiracy