Question

[Solved] phpMyAdmin Error: The mbstring extension is missing. Please check your PHP configuration

I have a problem running phpMyAdmin. When I try to access phpMyAdmin in my browser, I get the error message: “The mbstring extension is missing. Please check your PHP configuration.”

I have already searched on the internet for possible solutions. According to that, I made some modifications in php.ini file. I uncommented the line “;extension=php_mbstring.dll” and wrote the full path of the ext folder in extension_dir. Sadly, it still doesn’t work.

Could you please help me finding the proper solution.

Solution #1:

just run these command

sudo apt-get install phpmyadmin php-mbstring php-gettext

sudo service apache2 restart

Or you can follow this post…

Check This Post

Respondent: Sameer

Solution #2:

I’ve solved my problem by this way:
Edit the php.ini file:

  1. change extension_dir = “ext” into extension_dir = “D:phpext” ?please write ur own path?
  2. change ;extension=php_mbstring.dll into extension=php_mbstring.dll ?delete the “;”?
  3. Then just save your php.ini file and copy it to ur Windows directory?(“C:Windows“)
  4. restart the apache server?

The above is my solution,Hope it will work for u.

Respondent: hijack

Solution #3:

If you are ubuntu 14.04 and using php 5.6
You are missing out on mbstring and mysql module

Please install mbstring and mysql by

sudo apt-get install php5.6-mbstring
sudo apt-get install php5.6-mysql

and restart apache

sudo service apache2 restart
Respondent: Suraj

Solution #4:

It could happen after you update your php version, for instance if you upgrade from php5.6 to php7.1 you need to run these commands:

sudo apt-get install php7.1-mbstring
sudo service apache2 restart

If your destination version is different you need to check if the mbstring package exsit or not, an example for php7.0:

sudo apt-cache search php7.0-mbstring

I found it useful to first check existence of all modules that you working with, then performing an upgrade, in addition to that update phpmyadmin after upgrading your php is a good idea

Respondent: Arash Rabiee

Solution #5:

In my case i made a new installation of php7 using xampp, the error was in php.ini at line 699, i just did

include_path= C:Program Files (x86)xamppphpPEAR

to

include_path= "C:Program Files (x86)xamppphpPEAR"

and it worked for me.

I checked this by running the php.exe it gave me that error and i fixed it.

Respondent: Ahmed Ali

Solution #6:

Change extension_dir = "ext" to extension_dir = "C:/php/ext" in php.ini.

Respondent: Marek Wo?niak

Solution #7:

I have solved my problem by this way:

  1. Edit the c:phpphp.ini file:

  2. change extension_dir = “ext” into extension_dir = “c:phpext” ?please write
    ur own path?

  3. change ;extension=php_mbstring.dll into extension=php_mbstring.dll ?delete
    the “;”?
  4. restart the apache server?

I Hope it will work for u.

Respondent: Mohammed Khan

Solution #8:

This worked for me on Kali-linux 2018 :

apt-get install php7.0-mbstring

service apache2 restart
Respondent: Durodola Opemipo

Solution #9:

You also need to define PHPIniDirc:/php_install_path

Respondent: Jakab Molnár

Solution #10:

You can try this

sudo apt-get install phpmyadmin php-mbstring php-gettext
sudo ln -s /usr/share/phpmyadmin/ /var/www/html/phpmyadmin
service apache2 restart
Respondent: Mourad MAMASSI

Solution #11:

It could raise the concern if you’re either:

Case 1: Downgrading/ upgrading any PHP version.
Case 2: Enabling/Disabling (Switching) between PHP versions.

Here are some recommended commands I found helpful to fix these concerns:

Message 1: The mbstring extension is missing…….

sudo apt-get install php7.1-mbstring  

Message 2: The mysqli extension is missing…….

sudo apt-get install php7.1-mysqli

Note: Tested with PHP version 7.1. Change PHP version as per requirement.

Respondent: Vishal Kumar

Solution #12:

this ones solved my problem

1.open command prompt in administration

  1. then open apache bin folder like this,

    c: cd wampbinapacheapache2.4.17bin>

  2. then type after the above

    c: cd wampbinapacheapache2.4.17bin> mklink php.ini d:wampbinphpphp5.6.15phpForApache.ini

  3. thats it close the command prompt and restart the wamp and open it in admin mode.

  4. original post : PHP: No php.ini file thanks to xiao.

Respondent: Aravindh Gopi

Solution #13:

before you do other way, please do open php.exe on your PHP folder.
run it and if you faced any error statement on it, you can fix it manually.
else, do most-usefull post in this thread.

Respondent: zigots007

Solution #14:

I see this error after I disabled php5.6 and enabled php7.3 in ubuntu18.0.4

so i reverse it and problem resolved :DDD

Respondent: Hojjat

The answers/resolutions are collected from stackoverflow, are licensed under cc by-sa 2.5 , cc by-sa 3.0 and cc by-sa 4.0 .

Most Popular

To Top
India and Pakistan’s steroid-soaked rhetoric over Kashmir will come back to haunt them both clenbuterol australia bossier man pleads guilty for leadership role in anabolic steriod distribution conspiracy