[Solved] node_modules/rxjs/internal/types.d.ts(81,44): error TS1005: ‘;’ expected error after installation of Angular 6

I got an error of

node_modules/rxjs/internal/types.d.ts(81,44): error TS1005: ‘;’ expected.

after the installation of Angular 6.

Check the error:

ERROR in node_modules/rxjs/internal/types.d.ts(81,44): error TS1005: ';' expected.
node_modules/rxjs/internal/types.d.ts(81,74): error TS1005: ';' expected.
node_modules/rxjs/internal/types.d.ts(81,77): error TS1109: Expression expected.
Enquirer: SSP


Solution #1:

This problem might arise due to version mismatch. To solve your problem you need to do following changes in your package.json file.

Step 1 : Go to package.json and modify "rxjs": "^6.0.0" to "rxjs": "6.0.0"

Step 2 Run npm install in your project.

There is no need to change the typescript version. (Mine: "typescript": "~2.7.2")

Edit: If you are using rxjs-compat then you also need to do following in order to fixed the issue. change the rxjs-compat version from "rxjs-compat": "^6.2.2" to "rxjs-compat": "6.2.2"

Hope this will help!

Respondent: TheParam

Solution #2:

I had the same error
using angular 6 having [email protected] but i downgraded it to [email protected]
it worked.

Respondent: Shashikant Pandit

Solution #3:

You need to do some changes in package.json

Go to package.json and modify "rxjs": "^6.0.0" to "rxjs": "6.0.0"

Then run npm update in your project

Respondent: Sachith

Solution #4:

Go to the project directory run this command

npm install [email protected] –save

Respondent: shrikantbishoye

Solution #5:

If you are using rxjs-compat then you also need to do following in order to fixed the issue. change the rxjs-compat version from

"rxjs-compat": "^6.2.2" 


"rxjs-compat": "6.2.2"

This works for me

Respondent: Tuts Dev

Solution #6:

I just needed to edit the file and add the semicolon at the final line after 0 as shown here:

Go to the path [project directory]/node_modules/rxjs/internal and open the file types.d.ts as administrator, move to the final of the file and add a semicolon.

Original code: export declare type ObservedValueOf<O> = O extends ObservableInput<infer T> ? T : never;

Modified code: export declare type ObservedValueOf<O> = O; extends ObservableInput<infer T> ? T : never;

Solution #7:

Earlier, I used to fix the problem with @TheParam’s answer but lately started using yarn. Sadly I could not find yarn equivalent of

nmp update

I tried using

yarn upgrade

(although it is not equivalent of above command afaik) and it did not help.

I instead used

yarn add [email protected]6.0.0

and it worked. It took considerable time 82 sec as compared to few seconds in case of npm but fixed the issue. my node 8.11.2 and yarn 1.15.2

Respondent: user3792812

Solution #8:

I had same problem

npm install [email protected]2.8.0 

solved my problem

Respondent: Rita Punjabi

Solution #9:

Go to package.json and update “rxjs”: “^6.0.0” to “rxjs”: “6.0.0”
after that do npm update

Solution #10:

if you are still facing the problem,
go to package.json

  1. remove rxjs and add rxjs-compat
    “rxjs-compat”: “^6.4.0”
    “rxjs-compat”: “6.4.0”,

  2. change the typscript version to 2.8

  3. run npm install

This will work for you!

Respondent: Charuka Herath

Solution #11:

I had the same issue, the “rxjs”: “^6.0.0” to “rxjs”: “6.0.0” didn’t work. I had to update my angular CLI to last stable npm install -g @angular/cli and regenerate the project again.

My config now is :

Angular CLI: 7.3.6
Node: 10.15.3
OS: win32 x64
Angular: 7.2.9
Respondent: walox

Solution #12:

This issue is caused by version of typescript installed was not compatible with that of the rxjs installed.Installation of typescript as mentioned below helped me install the compatible version of typescript with that of the angular packages already installed.You can resolve the issue by the below command

npm install typescript 

This worked for me

Solution #13:

It is working fine with me when I changed “rxjs” in package.json from “^6.0.0” to “6.0.0”
and then run

“npm i”

Respondent: Menna Ramadan

Solution #14:

I got the same error.reason might be due to version mismatch

npm install [email protected] --save fix the error

Respondent: Sumith Ekanayake

Solution #15:

Just do the one changes in package.json file

"rxjs": "^6.0.0",

Just delete the ^ like i did in the below code & update the npm(node package manager)

"rxjs": "6.0.0",

npm update

ng serve --open

Now file your project will start normally

Respondent: Prasenjit Mahato

Solution #16:

This is my solution:

npm install [email protected]6.0.0 --save

ng server
Respondent: José Junior

Solution #17:

Go To package.json and modify “rxjs”: “^6.0.0” to “rxjs”: “6.0.0”

Then run

npm update

Then start the server

ng serve

Problem solved 100%

Respondent: Sushil

The answers/resolutions are collected from stackoverflow, are licensed under cc by-sa 2.5 , cc by-sa 3.0 and cc by-sa 4.0 .

Most Popular

To Top
India and Pakistan’s steroid-soaked rhetoric over Kashmir will come back to haunt them both clenbuterol australia bossier man pleads guilty for leadership role in anabolic steriod distribution conspiracy