Question

[Solved] MultipartException: Current request is not a multipart request

I am trying to make a restful controller to upload files. I have seen this
and made this controller:

@RestController
public class MaterialController {

    @RequestMapping(value="/upload", method= RequestMethod.POST)
    public String handleFileUpload(
            @RequestParam("file") MultipartFile file){
        String name = "test11";
        if (!file.isEmpty()) {
            try {
                byte[] bytes = file.getBytes();
                BufferedOutputStream stream =
                        new BufferedOutputStream(new FileOutputStream(new File(name + "-uploaded")));
                stream.write(bytes);
                stream.close();
                return "You successfully uploaded " + name + " into " + name + "-uploaded !";
            } catch (Exception e) {
                return "You failed to upload " + name + " => " + e.getMessage();
            }
        } else {
            return "You failed to upload " + name + " because the file was empty.";
        }
    }
}

and then i used postman to send a pdf:

enter image description here

But the server crashes with the error:

.MultipartException: Current request is not a multipart request

Again i have found this, and added a bean.xml file

<?xml version="1.0" encoding="UTF-8"?>
<beans xmlns="http://www.springframework.org/schema/beans"
       xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
       xsi:schemaLocation="http://www.springframework.org/schema/beans http://www.springframework.org/schema/beans/spring-beans.xsd">

    <bean id="multipartResolver"
          class="org.springframework.web.multipart.commons.CommonsMultipartResolver">
    </bean>
</beans>

Unfortunately, it still complains with the same error.

Enquirer: Jimmy

||

Solution #1:

When you are using Postman for multipart request then don’t specify a custom Content-Type in Header. So your Header tab in Postman should be empty. Postman will determine form-data boundary. In Body tab of Postman you should select form-data and select file type. You can find related discussion at https://github.com/postmanlabs/postman-app-support/issues/576

Respondent: Jimmy

Solution #2:

It looks like the problem is request to server is not a multi-part request. Basically you need to modify your client-side form. For example:

<form action="..." method="post" enctype="multipart/form-data">
  <input type="file" name="file" />
</form>

Hope this helps.

Respondent: abaghel

Solution #3:

I was also facing the same issue with Postman for multipart. I fixed it by doing the following steps:

  • Do not select Content-Type in the Headers section.
  • In Body tab of Postman you should select form-data and select file type.

It worked for me.

Respondent: Javier Z.

Solution #4:

In application.properties, please add this:

spring.servlet.multipart.max-file-size=128KB
spring.servlet.multipart.max-request-size=128KB
spring.http.multipart.enabled=false

and in your html form, you need an : enctype="multipart/form-data".
For example:

<form method="POST" enctype="multipart/form-data" action="/">

Hope this help!

Respondent: Nilesh Kumar

Solution #5:

Check the file which you have selected in the request.

For me i was getting the error because the file was not present in the system, as i have imported the request from some other machine.

Respondent: N.Luan Pham

Solution #6:

In my case, I removed:

‘Content-Type’: ‘application/json’,

from my Interceptor, and everything works.

     intercept(httpRequest: HttpRequest<any>, httpHandler: HttpHandler): Observable<HttpEvent<any>> {
if (this.authService.isUserLoggedIn() && httpRequest.url.indexOf('login') === -1) {
  const authReq = httpRequest.clone({
    headers: new HttpHeaders({
    'Content-Type': 'application/json',
      Authorization: this.authService.getBasicAuth()
    })
  });
  return httpHandler.handle(authReq);
} else {
  return httpHandler.handle(httpRequest);
}}
Respondent: KayV

Solution #7:

in ARC (advanced rest client) – specify as below to make it work
Content-Type multipart/form-data (this is header name and header value)
this allows you to add form data as key and values
you can specify you field name now as per your REST specification and select your file to upload from file selector.

Respondent: mzhehalo

Solution #8:

That happened once to me: I had a perfectly working Postman configuration, but then, without changing anything, even though I didn’t inform the Content-Type manually on Postman, it stopped working; following the answers to this question, I tried both disabling the header and letting Postman add it automatically, but neither options worked.

I ended up solving it by going to the Body tab, change the param type from File to Text, then back to File and then re-selecting the file to send; somehow, this made it work again. Smells like a Postman bug, in that specific case, maybe?

Respondent: Pravin Bansal

Solution #9:

i was facing the same issue with misspelled enctype=”multipart/form-data”, i was fix this exception by doing correct spelling .
Current request is not a multipart request client side error so please check your form.

Respondent: Haroldo_OK

Solution #10:

You need to add consumes = {MULTIPART_FORM_DATA_VALUE} to your mapping. Full example :

@PostMapping(path = "/{idDocument}/attachments", consumes = {MULTIPART_FORM_DATA_VALUE})
ResponseEntity<String> addAttachmentsToDocumentForm(@PathVariable Long idDocument, @RequestParam("file") MultipartFile[] files){
    documentService.addAttachments(idDocument, files);
    return ok("your response");
}
Respondent: Samarpan Patel

Solution #11:

i was facing this issue but it was due to the file i was uploading in postman wasn’t in the postman working directory
Go to Settings -> General and scroll down to location to find it’s location folder and put your files to upload there.

See : Setup Potman working directory

Respondent: Tomasz

The answers/resolutions are collected from stackoverflow, are licensed under cc by-sa 2.5 , cc by-sa 3.0 and cc by-sa 4.0 .

Most Popular

To Top
India and Pakistan’s steroid-soaked rhetoric over Kashmir will come back to haunt them both clenbuterol australia bossier man pleads guilty for leadership role in anabolic steriod distribution conspiracy