A python library that I’m using uses libxml2.2.dylib. I’m getting this error message:
Incompatible library version: etree.so requires version 12.0.0 or later, but libxml2.2.dylib provides version 10.0.0
My system’s version of
libxml2.2.dylib is older and is in
/usr/lib/. I downloaded the newest version of libxml2.2.dylib using homebrew, and that is in
I would like my Python application to use that version instead of the one the system uses.
Is this a matter of adding the homebrew folder to the path?
Try to follow the instructions here to build lxml with static dependencies. This way you don’t have to worry about which version of
libxslt it is linked against.
It could boil down to
STATIC_DEPS=true pip install -U lxml