[Solved] How to solve failed to find build tools revision 26.0.2?

I’m trying to Install Build Tools 26.0.2 and sync project

Failed to find build tools revision 26.0.2

I clicked “Install Build Tools 26.0.2 and sync project” but still failed …
Downloaded it from the external link .. but I don’t know where I put it.
So, What should I do? and THANKS


Solution #1:

Android Studio is looking for build tools 26.0.2, but build tools 27.0.3 is already released for Android Oreo 8.1

I am not totally sure why, but Android Studio doesn’t set the build tools in the gradle “app” file anymore. So here is how I fixed it. You get two options.

Method 1 – Install the missing build tools

1) Open the SDK manager by clicking on the icon in the top right of Android Studio. It looks like an android head in front of a download arrow. (Or go to File > Settings > Appearance & Behavior > System Settings > Android SDK)

2) Open SDK Tools tab

3) At the bottom-right, click “Show Package Details”

4) Find Android SDK Build-Tools and check the checkbox next to 26.0.2

5) Click apply in the bottom of the window

Method 2 – Use latest build tools

1) Follow instructions above

2) Uncheck all build tools besides 27.0.3 (the latest build tools at the time of writing)

Then you can define android build tools 27.0.3 in your gradle app file. To do this:

3) Make sure build tools 27.0.3 is installed by using the Android SDK manager (steps above).

4)Then find your build.gradle file. Use the navigation pane to the left of android studio. If it’s closed click the icon that looks like the android studio icon to the far left of android studio (it should have text that is sideways, and normally says “1:project”). Then use the file tree to find the file [yourappname] > app > build.gradle

5) Open the file and it should have something along the lines of “apply plugin: ‘'” as the first line. Then add a new line under “compileSDKVersion” type in buildToolsVersion “27.0.3”

6) Then sync your project and you should be good to go!

Respondent: Mohamed Alaa

Solution #2:

I have solved this problem by simply downloading the package with a standard browser Firefox, Chrome, etc.

The link itself is taken from the error logs of the Android Studio

Unzip it into the local folder


And then rename the unzipped folder to 27.0.3

After that, just sync the build.gradle and voila! The problem is solved.

Also in the SDK Manager try to use on the SDK Update Sites Tab the following option:

  • Force https://… sources to be fetched using http://…
Respondent: Anthony Alphabet

Solution #3:

i fix it! just like this
going to this local url: C:UsersuserAppDataLocalAndroidSdkuild-tools, and manually delete the folder 26.0.2 and then going back to android studio and click on the link to download build 26.0.2
that fix it

Respondent: Georgy Ivanov

Solution #4:

i have same problem , my activity_main can’t open because gradle project sync failed and i click “Install Build Tools 26.0.2 and sync project” and still failed

First , turn off kernel (file->seting->plugin->search kotlin then uncheck)
Then your android studio will reopen automaticly

After this i click again “Install Build Tools 26.0.2 and sync project” and now it’s works

If you wanna put from external link u can open :


Solution #5:
copy all files from [android-8.1.0] and move them into C:UsersuserAppDataLocalAndroidSdkuild-tools26.0.2

Respondent: Steven

Solution #6:

If you encounter this issue. simply go this website to download the required build tool for your project

Step 2 >> Extract the downloaded file

Step 3 >> Locate the build-tools folder inside your SDK e.g

Step 4 >> Paste the folder in the build-tools In my case, The default folder name was “Android-10” after I extracted the file but I change it to 29.0.2 since that’s the issue I wanted to solve

Step 5 >> Rebuild your project 🙂 .. Done!

enter image description here

Respondent: R.C.P.Rajapakshe

The answers/resolutions are collected from stackoverflow, are licensed under cc by-sa 2.5 , cc by-sa 3.0 and cc by-sa 4.0 .

Most Popular

To Top
India and Pakistan’s steroid-soaked rhetoric over Kashmir will come back to haunt them both clenbuterol australia bossier man pleads guilty for leadership role in anabolic steriod distribution conspiracy