Question

[Solved] How to restart ADB manually from Android Studio

I previously developped Android apps on Android Studio . Everything works fine.

I work on real device, and Android Studio recognize it without issue.

Suddenly when I exit android studio and disconnect and reconnect my device, it doesn’t recognize my device anymore, I have to exit and restart Android Studio.

I can’t find a way to “Reset adb” like Android Studio.

I follow the below instruction(Tools->Android->Enable ADB Integration) and enabled ADB,but still below error occurred.

Error:-

enter image description here

I using windows system.

Any help great appreciation.

Enquirer: RaMeSh

||

Solution #1:

Open Command promt and got android sdk>platform-tools> adb kill-server

press enter

and again
adb start-server

press enter

Respondent: Lakhwinder Singh

Solution #2:

open command prompt -> cd to your sdkplatform-tools
type below command:

adb kill-server && adb start-server
Respondent: Vrajesh

Solution #3:

  1. Open a Task Manager by pressing CTRL+ALT+DELETE, or right click at the bottom of the start menu and select Start Task Manager. see how to launch the task manager here

  2. Click on Processes or depending on OS, Details. Judging by your screenshot it’s Processes.

  3. Look for adb.exe from that list, click on END PROCESS

  4. Click on the restart button in that window above. That should do it.

Basically by suddenly removing your device ADB got confused and won’t respond while waiting for a device, and Android Studio doesn’t want multiple instances of an ADB server running, so you’ll have to kill the previous server manually and restart the whole process.

Respondent: matrixanomaly

Solution #4:

open cmd and type the following command

netstat -aon|findstr 5037

and press enter.

you will get a reply like this :

  TCP    127.0.0.1:5037         0.0.0.0:0              LISTENING       3372
  TCP    127.0.0.1:5037         127.0.0.1:50126        TIME_WAIT       0
  TCP    127.0.0.1:5037         127.0.0.1:50127        TIME_WAIT       0
  TCP    127.0.0.1:50127        127.0.0.1:5037         TIME_WAIT       0

this shows the pid which is occupying the adb. in this 3372 is the value. it will not be same for anyone. so you need to do this every time you face this problem.

now type this :

taskkill /pid 3372(the pid you get in the previous step) /f

Voila! now adb runs perfectly.

Respondent: Parth Anjaria

Solution #5:

I do not find a perfect way in Android Studio, get the process id and kill it from terminal:

ps -e | grep adb
kill -9 pid_adb
Respondent: BollMose

Solution #6:

Open task manager and kill adb.exe, now adb will start normally

Respondent: M. Usman Khan

Solution #7:

I faced same issue just fallowed some min steps in Android studio:

Manually fallowing steps in android studio

  1. Goto Command promt and in Command promt fallow a android SDK file path “android sdk>platform-tools>” adb kill-server press enter
  2. adb start-server press enter

————————————————-OR———————————————————————–

  1. Open Command promt and got android sdk file path
    adb kill-server && adb start-server
Respondent: PSP

Solution #8:

When I had this problem, I wrote adb kill-server and adb restart-server in terminal, but the problem appeared again the next day. Then I updated GPU debugging tools in the Android SDK manager and restarted the computer, which worked for me.

Respondent: Vladymir Yakymov

Solution #9:

AndroidStudio:

Go to: Tools -> Android -> Android Device Monitor

see the Device tab, under many icons, last one is drop-down arrow.

Open it.

At the bottom: RESET ADB.

Respondent: Ji?í

Solution #10:

After reinstalling Android Studio, Is working without adb kill-server

Respondent: calincan mircea

Solution #11:

If you are in Android Studio Open Terminal

 adb kill-server

press enter
and again

 adb start-server

press enter

Otherwise

Open Command prompt and got android

sdk>platform-tools> adb kill-server

press enter

and again

adb start-server

press enter

Respondent: Arslan Maqbool

Solution #12:

Make sure you have “USB debugging” turns on.

I never had this issue with my other devices before. However, today I worked on a device and encountered this issue. Actually took me a while to debug it. Always thought “USB debugging” is on automatically when turning on the “Developer Options“. But turns out its device dependent.

enter image description here

Respondent: Haomin

Solution #13:

Most of the answer is for restarting adb server in the command line.

Ji?í’s answer is the correct answer for this question (to restart adb server IN ANDROID STUDIO), though it’s been redesign as shown below.

go to Tools > Troubleshoot Device Connections

ps. you need to hit “Next” two times to find this Restart ADB server button.

enter image description here

Android Device Monitor was deprecated in Android Studio 3.1 and removed from Android Studio 3.2.

Respondent: Mia

The answers/resolutions are collected from stackoverflow, are licensed under cc by-sa 2.5 , cc by-sa 3.0 and cc by-sa 4.0 .

Most Popular

To Top
India and Pakistan’s steroid-soaked rhetoric over Kashmir will come back to haunt them both clenbuterol australia bossier man pleads guilty for leadership role in anabolic steriod distribution conspiracy