Question

[Solved] how to fix the issue “Command /bin/sh failed with exit code 1” in iphone

I used a cocoa static library in my application. When I compile my library I got the following error:

Shell Script invocation error:can't open input file:
/Users/sijuthomas/Library/Developer/Xcode/DerivedData/SCXML2-
    bbttehupryhijphhjdiemcytkvgy/Build/Products/Debug-iphonesimulator/
    libSCXMLParser.a (No such file or directory)
Command /bin/sh failed with exit code 1

Screenshot for error

How can I fix this?

Enquirer: Ben10

||

Solution #1:

 Target -> Build-Phases -> update examples

Click On Run checkbox if not selected.

Respondent: Harshad

Solution #2:

I had this issue because i denied keychain access and in order to solve it you need to open keychain,
Then click on the lock on top right of the screen to lock it again,
after that you can archive and it will work

Respondent: Salem Binmusaed

Solution #3:

Deleting “Derived Data” worked for me.

In Xcode go to File > Workspace Settings > Click the arrow next to the Derived Data file path > move the “Derived Data” folder to the trash.

Respondent: hgwhittle

Solution #4:

Seems you are running a shell script and it can’t find your specific file. Look at Target -> Build-Phases -> RunScript if you are running a script.

You can check if a script is running in your build output (in the navigator panel). If your script does something wrong, the build-phase will stop.

Respondent: Mr Bonjour

Solution #5:

I had same issue got it fixed. Use below steps to resolve issue in Xcode 6.4.

  1. Click on Show project navigator in Navigator window
  2. Now Select project immediately below navigator window
  3. Select Targets
  4. Select Build Phases tab
  5. Open Run Script drop-down option
  6. Select Run script only when installing checkbox

Screenshot for steps

Now, clean your project (cmd+shift+k) and build your project.

Respondent: Jayprakash Dubey

Solution #6:

Cleaning the build folder (Cmd + Shift + Alt + K) worked for me

Respondent: nb07

Solution #7:

1) Delete the pod folder and .xcworkspace file
2) Open the folder in terminal
3) Type “pod install”

Respondent: Akil

Solution #8:

Did you add the .a library to the xcode projet ? (project -> build phases -> Link binary with libraries -> click on the ‘+’ -> click ‘add other’ -> choose your library)

And maybe the library is not compatible with the simulator, did you try to compile for iDevice (not simulator) ?

(I’ve already fight with the second problem, I got a library that was not working with the simulator but with a real device it compiles…)

Respondent: Ashbay

Solution #9:

In My case there was space in the path that was failing the script.If you are using variables like $PROJECT_DIR or $TARGET_BUILD_DIR then replace them "$PROJECT_DIR" or "$TARGET_BUILD_DIR" respectively.After adding quotes my script ran successfully.

Respondent: Desert Rose

Solution #10:

For me, my certificate is expired. I have created a new certificate.

Respondent: Vincent Sit

Solution #11:

I tried restarting Xcode (7) and nothing (the have you tried switching it off and on again of iOS development for me :-)). I then tried by restarting my box and that worked.

In my case the script was failing when copying a file from a location to another one. I think it could have been related to Finder screwing with writing rights over certain folders.

Respondent: Juan Fran Jimenez

Solution #12:

For me this error was occuring because I changed the version number from 1 to 1.0 and build number from 6 to 1.1 as I pulled the code from source tree. I just changed it back and changed the build number from 6 to 7and it worked fine.

Respondent: Chaudhry Talha

Solution #13:

just put your script in a file and run that file with 2>/dev/null at the end of command line!

This way, if there is a problem with the command whatsoever, it will not halt your xcode build

in my case I was running just a command to uninstall my previous copy of the app from a connected iphone, so it could give an error if the iphone is not there. To solve it:

$mobiledevice uninstall_app com.my.app 2>/dev/null

Respondent: Saeed Badran

Solution #14:

The only thing worked for me:

1) Delete Derived Data with CleanMyMac: System Junk -> Xcode Junk -> Xcode Derived Data

Deleting Derived Data with CleanMyMac

2) Then in Xcode: Product -> Clean

Respondent: ??????? ?

Solution #15:

I did all above and spent an hour on the issue.

Tried everything above as well as restarted Xcode.

Finally, restarted computer and everything working normally again!

Respondent: Luke Mccormick

Solution #16:

I’ll list things I did that did not work for me and finally what did

First, the accepted answer of Run script only when installing did not work.

Deleting derived data did not work.

What did work:

  1. I added a new build phase in Build Phases

  2. New Copy Files Phase

  3. Drag & Drop the chosen framework into the drop target

  4. Set the ‘Destination’ to Frameworks

Credit due to Kevin Le’s Medium post

Respondent: FullMetalFist

Solution #17:

For those who doesn’t want to uncheck that option (using cocoapods for example), the problem might be with the certificate/key.

Xcode (or whatever tool you are using, like a command line tool) needs to be able to use the certificate/key from the keychain. For this open the Keychain, locate the certificate that you want to use (Usually on login keychain, My Certificates), right click on the key, select Get Info, click on Access Control tab and add the app to the list.

If this doesn’t work, try unlocking the keychain.

Another option can be select Allow all applications to access this item instead of specific apps and/or move the certificate/key to System keychain which is shared between all the user accounts on that Mac.

Also check that the certificate is not expired.

Respondent: rgkobashi

Solution #18:

1) option : Please check run the script only when installing......  it is right to answer of this question

2) option : pod update, clean derive data,

Respondent: sumit rathore

Solution #19:

In my case, one of the script (related to SwiftGen) was failing during compilation.

I fixed the issue by removing the Pods and then updating them again.

  1. Remove the problematic pod under Pods directory or use pod deintegrate
  2. Install / Update the pods using pod install or pod update

P.S. It is possible your dependency is Global and is not in pods. In that case you can also try to reinstall that dependency.

Respondent: Haseeb Iqbal

Solution #20:

READ THIS IF YOU USE Crashlytics AND ARE HAVING THIS ISSUE…

I was having the same issue as above Command /bin/sh failed with exit code 1 more specifically [31merror: Could not fetch upload-symbols settings: An unknown error occurred fetching settings.[0m

The first solution (enabling the run script only when installing) allowed me to build my target in the simulator, but I could not archive my build.

I solved this Archive issue by enabling Crashlytics on firebase. I am still used to Fabric where Crashlytics is automatically enabled. Once I enabled Crashlytics in the firebase console for the corresponding GoogleService-Info.plist I was able to Archive without this error.

Respondent: NicholasTM

Solution #21:

Remove all pods and install again.

Steps:

  1. comment all pods and run pod install
  2. uncomment all pods and run pod install
Respondent: MuhammadGad

The answers/resolutions are collected from stackoverflow, are licensed under cc by-sa 2.5 , cc by-sa 3.0 and cc by-sa 4.0 .

Most Popular

To Top
India and Pakistan’s steroid-soaked rhetoric over Kashmir will come back to haunt them both clenbuterol australia bossier man pleads guilty for leadership role in anabolic steriod distribution conspiracy