Question

[Solved] Genymotion: The virtual device got no IP address?

Whenever I try to launch my virtual device in Genymotion, I receive an error stating that it has no ip address. DHCP is enabled in VirtualBox and it all seems fine to my knowledge. I tried disabling/enabling the network adapter too, no luck. Also did a full re-install. Not sure what else to do. I am open to suggestions.

System:
Windows 10 x64
Quad Core CPU 3.0 ghz
4 GB RAM

Solution #1:

After 2 days R&D I found solution.

Steps 1:

Go to BIOS settings -> Go to System Configuration -> Enable Virtualization Technology -> Save and Exit from BIOS settings.

Steps 2:

Open Oracle VM VirtualBox -> Select your simulator -> Go to settings of simulator -> Select General tab -> Select Basic sub tab -> Select your OS type -> Select your Version of your OS -> Save and Exit

Steps 3:

Restart your Genymotion and Start Genymotion simulator.

Reference Screenshots:

Steps 1:

enter image description here

Steps 2:

enter image description here

Hope this would help you.

Respondent: Aleksandar Zoric

Solution #2:

Step1
Ensure you have Virtualization Technology enabled in your BIOS.

Step 2
Open Virtualbox and go to “File » Preferences” (CTRL+G), then head over “Network » Host-only adapters“,click the “minus” button. Confirm it, and try after restarting your PC.

Step 3
If above solution does not work for you delete virtual machine from Genymotion and re install the Virtual Machine by Clicking add button.

Step 4
Another trick is exit all those programs which are using internet for example browser,skype,teamviewer etc. Then run genymotion and now launch your emulator.
After successful launch of emulator you can launch any program.

Respondent: Hiren Patel

Solution #3:

No one responded to Mac users, in my case it was much easier.

  • Just turn-off the wi-fi and turn-on

… that’s all. It recovers a new IPenter image description here

Respondent: Hashtech

Solution #4:

Check if your CPU has support for Virtualization Technology, and enable it in BIOS if it was disabled. This is required by most of Genymotion Virtual Devices, otherwise they will not work.
If this step is OK, maybe you will find your case there:

Genymotion – The virtual device got no IP Address

Not able to start Genymotion device

Respondent: Mini Cisne

Solution #5:

try to clear the cache in genymotion
Setting -> Misc -> Clear cache.

Check this image

maybe it will solve the problem.

Respondent: B-GangsteR

The answers/resolutions are collected from stackoverflow, are licensed under cc by-sa 2.5 , cc by-sa 3.0 and cc by-sa 4.0 .

Most Popular

To Top
India and Pakistan’s steroid-soaked rhetoric over Kashmir will come back to haunt them both clenbuterol australia bossier man pleads guilty for leadership role in anabolic steriod distribution conspiracy