Question

[Solved] file not found Google Maps SDK for iOS

Yesterday I recived an email from google saying that I could acces to the map api for ios, I generated my key from the app console and I follow the steps of https://developers.google.com/maps/documentation/ios/start but xcode throw this error.

#import <GoogleMaps/GoogleMaps.h> //file not found

Thanks for your support.

It is normal that appears the Headers executable instead of the folder?

enter image description here

SOLVED!

Solution #1:

Make sure you unzip the SDK with something which understands symbolic links.

GoogleMaps.framework/Headers is a symbolic link to GoogleMaps.framework/Versions/A/Headers.

When I unzip it on my Mac the symbolic link is set up correctly. But when I unzip it on my PC instead of symbolic links I get text files which just contain the path (eg Versions/Current/Headers).

If you unzip on a PC and then copy the folder to your Mac (or unzip using some other method which doesn’t create symbolic links), then you will get the error you see.

Respondent: ƒernando Valle

Solution #2:

Finally I have found the solution for my problem:

1 Extract the subfolder A in version and I renamed it to
GoogleMaps.framework

2 Copy this folder to your project folder.

enter image description here

3 Add it to your Frameworks group in the project

enter image description here

4 Import to AppDelegate as #import "GoogleMaps/GoogleMaps.h"

I will edit with images for people that have the same trouble.

Thanks for all the people that helped me.

Respondent: Saxon Druce

Solution #3:

Try this:

Drag the GoogleMaps.framework bundle to the Frameworks group of your project. When prompted, select Copy items into destination group’s folder.

You have to copy the unzipped folder “GoogleMaps.framework” into XCode.

Then follow steps 3 & 4

3.Right-click GoogleMaps.framework in your project, and select Show In Finder.

4.Drag the GoogleMaps.bundle from the Resources folder to your project. We suggest putting it in the Frameworks group. When prompted, ensure Copy items into destination group’s folder is not selected.

If still not working try adding manually GoogleMaps.framework in the Build Phases tab->Link Binary with Libraries

Respondent: ƒernando Valle

Solution #4:

Here’s the first few steps you need:

  • Download GoogleMaps-iOS-1.1.0.zip from their site
  • Unzip the file. You now have a GoogleMaps-iOS-1.1.0 folder
  • In that folder you have a GoogleMaps.framework folder.
  • Copy or move the GoogleMaps.framework folder to inside your project folder (in Finder).
  • Drag the GoogleMaps.framework folder onto your Frameworks group in Xcode.
  • In the options sheet, uncheck “Copy items into destination group’s folder”. Make sure your target is checked in “Add to targets”. Click OK.
  • (Note that you can also do this the other way, by not copying it into your project folder and checking “Copy items into destination group’s folder”. Xcode will copy the folder itself.)

  • Import using #import "GoogleMaps/GoogleMaps.h". The angle bracket usually work too, but in this case it should use quotes.

You should end up with a golden toolbox icon:

enter image description here

Using an #import with angle brackets should search the system frameworks, then inside your project folder, but to be safe try it with quotes.

Respondent: PGLongo

Solution #5:

the GoogleMaps framework is probably not in the Library folder but in the same directory like all other project files. I this case you have to write #import "GoogleMaps/GoogleMaps.h or #import "GoogleMaps.h"

Respondent: nevan king

Solution #6:

I’ve been struggling with this issue for hours; I’m using CocoaPods, Swift and Xcode 6.1.1. I followed all the steps for including GoogleMaps in my project carefully, tried many different things like removing symbolic links in the downloaded package or manually linking the binaries in build phases or trying #include "GoogleMaps.h", #include "GoogleMaps/GoogleMaps.h" and "#include <GoogleMaps/GoogleMaps.h> in my bridge file, none of that worked… Finally used CocoaPods instead of including the framework myself and it worked! Hope it helps someone out there:

In the Podfile:

pod 'Google-Maps-iOS-SDK', '~> 1.9.2'

And in your Bridge file:

#import "GoogleMaps.h"

Respondent: Areal-17

Solution #7:

make sure you upgrade to the latest sdk.
v1 and v3 were different.
had trouble getting v1 to work

Respondent: Soheil Jadidian

Solution #8:

Maybe you’ve forgot after change Podfile, you have to run

pod update

then rerun react-native run-ios

Respondent: brian.clear

Solution #9:

Its better install Pod for google map, Just add google maps into pod.
Note if you don’t have pod file in your project folder ios/ then do below steps
pod init

the add below code in your pod file

platform :ios, '9.0'

target 'YourAppTarget' do
  pod 'GoogleMaps'  # <~~ remove this line if you do not want to support GoogleMaps on iOS
end
# pre_install do |installer|
   # copied from https://github.com/CocoaPods/CocoaPods/issues/2926
   # workaround for https://github.com/CocoaPods/CocoaPods/issues/3289
  #  def installer.verify_no_static_framework_transitive_dependencies; end
# end

target 'YourAppTarget-tvOS' do

end

Do not forget to add AirGoogleMaps to your project directory from
node_modules/react-native-maps/lib/ios

Respondent: ManhNguyen

Solution #10:

This answer will also might help you. The above all answers are not worked for me at last after a long time i found like this

# import "GoogleMapsM4B/GoogleMaps.h"

Use like this it definitely solves your problem

Respondent: Sadanand

The answers/resolutions are collected from stackoverflow, are licensed under cc by-sa 2.5 , cc by-sa 3.0 and cc by-sa 4.0 .

Most Popular

To Top
India and Pakistan’s steroid-soaked rhetoric over Kashmir will come back to haunt them both clenbuterol australia bossier man pleads guilty for leadership role in anabolic steriod distribution conspiracy