Question

[Solved] Error:SSL peer shut down incorrectly In Android studio 3.0.1

When I build the project I receive the following error
Error:SSL peer shut down incorrectly please let me know how to fix this error

Solution #1:

It’s probably a certificate problem, I had similar issue with Android Studio and I solved it by following these steps:

1 – Open gradle-wrapper-properties file and modify https:// to http://

2 – Force using http instead of https in Android SDK Manager, just click on SDK Manager icon above on Android Studio Toolbar and go to SDK Update Sites tab.

3 – Go to File -> Settings. In the IDE Settings section select Server Certificates, then check accept non-trusted certificates automatically.
If the problem persist, then you should add the certificates to Android Studio, like *.google.com certificate.
In my case I tried to add multiple certificates but I still get SSL Error, After I opened https://services.gradle.org in my browser and I imported the certificate to Android Studio, Anyhow adding this as an SSL exception resolved the issue for me.

If the problem persist, I recommend to configure a proxy to just
install the desirable dependencies. Open Gradle properties for
proxy settings and add the following:

systemProp.http.proxyHost=x
systemProp.https.proxyPort=y
systemProp.https.proxyHost=x
systemProp.http.proxyPort=y
Respondent: iLyas

Solution #2:

My problem was solved Clean Project and then `Rebuild Project..
Hope this helps you,,

Solution #3:

You have a slow Internet Connection & Your Android Studio Build got interrupted.
Try to build in offline mode or fix your internet

Respondent: user987760

Solution #4:

Files -> Invalidate cashes / restart -> Invalidate and Restart.

This will solve the problem.

Respondent: kalandar

Solution #5:

For fixing this problem you can use a vpn.

Respondent: Benyamin

Solution #6:

after testing other answers and nothing happened, I try a trick
open another project that is synced successfully, find gradle version and gradle plugin version and use those in current project

project structure menu button
just copy gradle version and gradle plugin version and use them in other project and sync

enter image description here

Respondent: hzandi

Solution #7:

This may not be a generic answer, but I was able to solve it this way.
If you’re using the security software Kaspersky, try closing it and then running it.

Solution #8:

Please check your internet and try again

Solution #9:

It is related to your Internet connection;

First Solution :
Check your connection and turn off proxy, if you are using.

Second Solution :
Change your proxy region to another and try again.

Respondent: sina akbary

Solution #10:

Go to Android SDK manager and update with latest SDK. After downloading just re syncy and error will be gone

Solution #11:

Try to clean your project.
If the problem does not solved use a proxy and sync your gradle and rebuild the project(if you are already using proxy server try to use an other one and be sure that your internet connection is stable).

Respondent: Manar Alkull

Solution #12:

Go to SDK Manager , then select SDK Update Sites and lastly Mark/Tick “Force https://….’

Respondent: Seynation Media

Solution #13:

I don’t know if it has to do, but I removed the VCS and resynced, it took a lot of time, then I clicked on the syncing process and I resumed something that was paused. Then it worked.

Respondent: YoussefDir

Solution #14:

Hey Just update the classpath to latest version available I solved the error by this
just write classpath ‘com.android.tools.build:gradle:your.latest.version’

The answers/resolutions are collected from stackoverflow, are licensed under cc by-sa 2.5 , cc by-sa 3.0 and cc by-sa 4.0 .

Most Popular

To Top
India and Pakistan’s steroid-soaked rhetoric over Kashmir will come back to haunt them both clenbuterol australia bossier man pleads guilty for leadership role in anabolic steriod distribution conspiracy