[Solved] Error:(9, 5) error: resource android:attr/dialogCornerRadius not found

So I installed android studio 3.0.1 and as soon as it opened the gradle built and showed the following errors. I tried adding dependencies such as design and support but in vain. Could someone help me?
Thank you in advance.
enter image description here

It shows that some attributes such as dialogCornerRadius and fontVariation Settings not found.

Solution #1:

This error occurs because of mismatched compileSdkVersion and
library version.

for example:

compileSdkVersion 27
implementation ''
implementation ''

and also avoid to use + sign with library as in the following:

implementation ''

use exact library version like this

implementation ''

Using + sign with the library makes it difficult for the building process to gather the exact version that is required, making system unstable, hence should be discouraged.

Respondent: Sheharyar Ejaz

Solution #2:

If you are migrated for AndroidX and getting this error, you need to set the compile SDK to Android 9.0 (API level 28) or higher

Respondent: murgupluoglu

Solution #3:

I had the exact same issue. The following thread helped me solve it. Just set your Compile SDK version to Android P.

I fixed this issue by selecting:

API 27+: Android API 27, P preview (Preview)

in the project structure settings. the following image shows my
settings. The 13 errors that were coming while building the app, have

Gradle settings

Respondent: Adnan Mulla

Solution #4:

Check your dependencies for uses of + in the versions. Some dependency could be using This leads to problems when a new version gets released and could break features.

The solution for this would be to either use{compileSdkVersion}.+ or don’t use + at all and use the full version (ex.

If you cannot see a line in your build.gradle files for this, run in android studio terminal to give an overview of what each dependency uses

gradlew -q dependencies app:dependencies --configuration debugAndroidTestCompileClasspath (include androidtest dependencies)


gradlew -q dependencies app:dependencies --configuration debugCompileClasspath (regular dependencies for debug)

which results in something that looks close to this

Project :app

debugCompileClasspath - Resolved configuration for compilation for variant: debug
|    +---
|    +--- (*)
|    +---
|    |    +---
|    |    --- (*)
|    ---
|         +--- (*)
|         --- (*)
|    +--- (*)
|    +--- (*)
|    +---
|    |    +---
|    |    +--- (*)
|    |    --- (*)
|    ---
|         +---
|         --- (*)
|    ---

(*) - dependencies omitted (listed previously)

If you have no control over changing the version, Try forcing it to use a specific version.

configurations.all {
    resolutionStrategy {
        force ""
        force ""

The force dependency may need to be different depending on what is being set to 28.0.0

Respondent: btelman96

Solution #5:

Had the same issue while working on an application with several modules, check to make sure as you increase the compileSdkVersion and targetSdkVersion to 28+ values in a module you also do for the others.

A module was running on compileSdkVersion 29 and targetSdkVersion 29 while a second module of the application was running on compileSdkVersion 27 and targetSdkVersion 27.

Changing the second module to also compile for and target SDK version 29 resolved my issue. Hope this helps someone.

Respondent: Opeyemi

Solution #6:

Maybe it’s too late but i found a solution:

You have to edit in the build.gradle either the compileSdkVersion –> to lastest (now it is 28). Like that:

android {
compileSdkVersion 28
defaultConfig {
    minSdkVersion 21
    targetSdkVersion 28
    versionCode 1
    versionName "1.0"
    testInstrumentationRunner ""

or you can change the version of implementation:

dependencies {
    implementation fileTree(dir: 'libs', include: ['*.jar'])
    api ''
    implementation ''
    implementation ''
    testImplementation 'junit:junit:4.12'
    androidTestImplementation ''
    androidTestImplementation ''
Respondent: Indigo0087

Solution #7:

try to change the compileSdkVersion to: compileSdkVersion 28

Respondent: EstevĂŁo Lucas

Solution #8:

This Is Because compileSdkVersion , buildToolsVersion and Dependecies implementations are not match
You Have to done like this i have 28 library then

compileSdkVersion 28
targetSdkVersion   28
buildToolsVersion  28.0.3
implementation ''
implementation ''

If we You Use Any where less than 28 this error should occured so please try match library in all.

Respondent: Sahil Choudhary

Solution #9:

I was having the same issue while adding a mapbox navigation API and resolved this issue by going to: file>project Structure and then setting the compile sdk version and build tool version to the latest.
And here is the screenshot:
settings Screenshot

Hope it helps.

Respondent: Haroon khan

Solution #10:

Found a neat plugin to solve this:

cordova plugin add cordova-android-support-gradle-release –variable ANDROID_SUPPORT_VERSION=27.+ –save

Respondent: zi88

Solution #11:

In my case, I was getting this error in AndroidStudio 4.1.1 while updating compileSdkVersion to 29.

If you are having dependent project in build.gradle, All you need to do is Update same compileSdkVersion in dependent project’s build.gradle as well.


  1. Click on your app folder in Project view of AndroidStudio.
  2. Select Open Module Settings.
  3. In Project Structure >> Check how many modules are there?
  4. If there are more than one modules, you will have to update compileSdkVersion, buildToolsVersion & Project dependency as well.

That worked for me 🙂

Respondent: shroffakshar

Solution #12:

in my case, I try tried File>Invalidate Cache/Restart and that works for me.

Respondent: Rohit Mandiwal

Solution #13:

The dependencies must be applied as shown below to solve this issue :

dependencies {
implementation fileTree(include: ['*.jar'], dir: 'libs')
implementation ''
testImplementation 'junit:junit:4.12'
androidTestImplementation ''
androidTestImplementation ''
implementation ''
implementation ''
implementation ''

Please do not use the version of :


Respondent: Sanche

Solution #14:

I faced the same problem but I successfully solved the problem by changing the version of compileSdkVersion to the latest which is 29 and change the version of targetSdkVersion to the latest which is 29.

Go to the file and change the compilesdkversion and targetsdkversion.

Respondent: Hadayat ullah

Solution #15:

In my case, this error ocurred while i was using

implementation ''
implementation ''

libraries together with googles

implementation ''

library. If this is the case in your project, i highly recommend to fully remove the google material components library from your project.

Respondent: laim2003

Solution #16:

 buildscript {

    project.ext {
        supportLibVersion = '27.1.1'
        compileVersion = 28
        minSupportedVersion = 22

and set dependencies:

implementation "$project.supportLibVersion"
Respondent: Viral Patel

Solution #17:

Update them from build.gradle project

classpath ‘’

classpath ‘’

and update from build.gradle app

compileSdkVersion = 30

buildToolsVersion = ‘29.0.3’

targetSdkVersion = 29

last thing update gradle from


Respondent: Mark Nashat

The answers/resolutions are collected from stackoverflow, are licensed under cc by-sa 2.5 , cc by-sa 3.0 and cc by-sa 4.0 .

Most Popular

To Top
India and Pakistan’s steroid-soaked rhetoric over Kashmir will come back to haunt them both clenbuterol australia bossier man pleads guilty for leadership role in anabolic steriod distribution conspiracy