Question

[Solved] Error: npm WARN deprecated [email protected]: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue

I have this problem during installation of ionic cordova:

npm WARN deprecated [email protected]: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue

Please anyone helpme

Solution #1:

You need to update your minimatch version
Follow these steps:

Run this command to update minimatch

$ npm update minimatch

Run this command to check minimatch version

$ npm -v minimatch

If the version is still old one Run this command

$ npm install -g [email protected]

Check your version again

$ npm -v minimatch
Respondent: PHP Worm…

Solution #2:

Here, I worked in redux-Saga and try to install npm in my directory. At that time I found this error. I have solved this error by below command,

Run this command in cmd:

   npm install browserify babelify babel-preset-env
Respondent: Yogesh Borad

Solution #3:

I fixed this error by deinstalling nodejs v4.x (64-bit) and installing the latest nodejs v6.3.0 (32-bit). after that i installed cordova with ‘npm install -g cordova’
I use a windows machine. I hope this helps anyone 🙂

Before that i deleted all my node_modules npm and npm-cache folders in my home directory and appdata -> roaming directory

Respondent: code1x1.de

Solution #4:

if your node js running in v 4.xx,

  1. remove first your npm and npm cache on your appData/roaming …
  2. Uninstalling your node js
  3. Upgrade your Node js to v6.x (or latest version)

Hope this helps 😀

Respondent: Erdendi Lesmana

Solution #5:

I was able to fix the error by re-installing node as suggested by Erdendi Lesmana. So now minimatch version is updated

$ npm -v minimatch
3.10.8

but I still cannot install cordova

sudo npm install -g cordova
npm WARN deprecated [email protected]: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue

can someone help please.

Respondent: prashmi

Solution #6:

this is an npm error related to versioning. upgrade your minimatch to the latest version and the error will likely go away.

Respondent: johnwargo

The answers/resolutions are collected from stackoverflow, are licensed under cc by-sa 2.5 , cc by-sa 3.0 and cc by-sa 4.0 .

Most Popular

To Top
India and Pakistan’s steroid-soaked rhetoric over Kashmir will come back to haunt them both clenbuterol australia bossier man pleads guilty for leadership role in anabolic steriod distribution conspiracy