Question

[Solved] Error: “Adb connection Error:An existing connection was forcibly closed by the remote host”

When I tried to reset my adb the following error occurs:

[2011-09-14 09:34:06 - DeviceMonitor]Adb connection Error:An existing connection was forcibly closed by the remote host
[2011-09-14 09:34:07 - DeviceMonitor]Connection attempts: 1

I am just making a simple “hello world” program.

Solution #1:

Well, its not compulsory to restart the emulator you can also reset adb from eclipse itself.

1.)
Go to DDMS and there is a reset adb option, please see the image below.

enter image description here

2.) You can restart adb manually from command prompt

  run->cmd->your_android_sdk_path->platform-tools>

Then write the below commands.

adb kill-server – To kill the server forcefully

adb start-server – To start the server

UPDATED:

F:android-sdk-windows latestplatform-tools>adb kill-server

F:android-sdk-windows latestplatform-tools>adb start-server
* daemon not running. starting it now on port 5037 *
* daemon started successfully *
Respondent: Lalit Poptani

Solution #2:

Change to another USB port works for me.
I tried reset ADB, but problem still there.

Respondent: Jason H

Solution #3:

Looks like the installed driver was in bad state. Here is what I did to make it work:

  1. Delete the device from Device Manager.
  2. Rescan for hardware changes.
  3. “Slate 21” will show up with “Unknown driver” status.
  4. Click on “Update Driver” and select /extras/google/usb_driver
  5. Device Manager will find the driver and warn you about installing it. Select “Yes.”

This time the device got installed properly.

Note that I didn’t have to modify winusb.inf file or update any other driver.

Hope this helps.

Respondent: Peter

Solution #4:

I know I’m 4 years late but my answer is for anyone who may not have figured it out. I’m using a Samsung Galaxy S6, what worked for me was:

  1. Disable USB debugging

  2. Disable Developer mode

  3. Unplug the device from the USB cable

  4. Re-enable Developer mode

  5. Re-enable USB debugging

  6. Reconnect the USB cable to your device

It is important you do it in this order as it didn’t work until it was done in this order.

Respondent: kaio37k

Solution #5:

In my case, resetting ADB didn’t make a difference. I also needed to delete my existing virtual devices, which were pretty old, and create new ones.

Respondent: Brian Bowman

Solution #6:

Window->Show View->device (if not found ->Other->Device) in right most side, there is arrow, click that, you will see reset adb, just click and enjoy!! It worked for me.

Respondent: xedi.pawan

Solution #7:

In my case, which none of the answers above stated. If your device is using the miniUsb connector, make sure you are using a cable that is not charge-only. I became accustom to using developing with a newer Usb-C device and could not fathom a charge-only cable got mixed with my pack especially since there is no visible way to tell the difference.

Before you uninstall and go through a nightmare of driver reinstall and android menu options. Try a different cable first.

Respondent: Dave Friedel

The answers/resolutions are collected from stackoverflow, are licensed under cc by-sa 2.5 , cc by-sa 3.0 and cc by-sa 4.0 .

Most Popular

To Top
India and Pakistan’s steroid-soaked rhetoric over Kashmir will come back to haunt them both clenbuterol australia bossier man pleads guilty for leadership role in anabolic steriod distribution conspiracy