Question

[Solved] Could not open input file: composer.phar

I am trying to install zendframework using composer tool in wamp server.

The following steps are done towards installation

  1. I downloaded the Composer-Setup.exe file from composer page and got successfully installed.

  2. I downloaded the zendframework and extracted inside the c:wampwwwzend folder

  3. I executed the command for self update

    php composer.phar self-update

This line generates the error message: could not open file composer.phar

how to resolve this error

If I try the

composer.phar self-update

enter image description here

Enquirer: Sundar

||

Solution #1:

Use this :

php -r "readfile('https://getcomposer.org/installer');" | php

This will install composer to the current directory so that you can use php composer.phar

Respondent: Kamesh Jungi

Solution #2:

The composer.phar install is not working but without .phar this is working.

We need to enable the openssl module in php before installing the zendframe work.

We have to uncomment the line ;extension=php_openssl.dll from php.ini file.

composer use different php.ini file which is located at the wampbinphpphp-<version number>php.ini

After enabling the openssl we need to restart the server.

The execute the following comments.

I can install successfully using these commands –

composer self-update
composer install --prefer-dist

enter image description here

Respondent: Sundar

Solution #3:

I was trying to install YII 2.0

php composer.phar create-project yiisoft/yii2-app-advanced advanced 2.0.0-alpha

I got the same error:

Could not open input file: composer.phar

Then i gave the full path of .phar like this:

php C:ProgramDataComposerbincomposer.phar create-project yiisoft/yii2-app-advanced advanced 2.0.0-alpha

and it worked.

Respondent: Atta Ur Rehman

Solution #4:

I am using Windows 7, and I got the same problem as yours while using Composer via cmd.

The problem is solved when I use

php C:ProgramDataComposerSetupbincomposer.phar create-project slim/slim-skeleton

instead of

php composer.phar create-project slim/slim-skeleton

Hope this is useful for people who got the same problem.

Respondent: DarkSpirit

Solution #5:

First try this: dont use the php composer.phar [parameters] simply use composer [parameters] if this doesn’t work for you than try the rest. Hope it helps.

Respondent: Michael Sebastian

Solution #6:

Initially, I was running php composer.phar self-update and got the same error message.

As a resolve, you should use composer command directly after install it.From the command prompt, just type composer and press enter.

If composer is installed correctly then you should able to see a lot of suggestion and command list from composer.

If you are up to this point then you should able to run composer self-update directly.

Respondent: kta

Solution #7:

Question already answered by the OP, but I am posting this answer for anyone having similar problem, retting to

Could not input open file: composer.phar

error message.

Simply go to your project directory/folder and do a

composer update

Assuming this is where you have your web application:

/Library/WebServer/Documents/zendframework

change directory to it, and then run composer update.

Respondent: Pmpr

Solution #8:

dont use php composer.phar self-update
First go to Your project directory
simply use composer.phar self-update
This works for me

Respondent: Rajesh Patel

Solution #9:

I have fixed the same issue with below steps

  1. Open project directory Using Terminal (which you are using i.e. mintty )
  2. Now install composer within this directory as per given directions on https://getcomposer.org/download/

php -r “copy(‘https://getcomposer.org/installer‘, ‘composer-setup.php’);”

php -r “if (hash_file(‘SHA384’, ‘composer-setup.php’) === ‘the-provided-hash-code’) { echo ‘Installer verified’; } else { echo ‘Installer corrupt’; unlink(‘composer-setup.php’); } echo PHP_EOL;”

php composer-setup.php
php -r “unlink(‘composer-setup.php’);”

  1. Now run your command.

Everything is working fine now because the composer.phar file is available within the current project directory.

Copied from https://stackoverflow.com/questions/21670709/running-composer-returns-could-not-open-input-file-composer-phar/51907013#51907013

thanks

Respondent: Anoop Saini

Solution #10:

This is how it worked for me:

  • Make sure composer is installed without no errors.

  • Open “System Properties” on windows and go to the “Advanced” tab. (You can just press the windows button on your keyboard and type in “Edit the system environment variables`

  • “Environment variables”

  • Under “System variables” Edit “PATH”

  • Click on “New”.

  • Type in: C:ProgramDataComposerSetupbincomposer.phar

  • Close all folders & CMDs + restart you WAMP server.

  • Go to whatever directory you want to install a package in and type in

    composer.phar create-project slim/slim-skeleton

for example.

Respondent: W.Doch

Solution #11:

Try in command line:

curl -sS https://getcomposer.org/installer | php
Respondent: Wolf

Solution #12:

Instead of

php composer.phar create-project --repository-url="http://packages.zendframework.com" zendframework/skeleton-application path/to/install

use

php composer.phar create-project --repository-url="https://packages.zendframework.com" zendframework/skeleton-application path/to/install

Just add https instead of http in the URL. Though it’s not a permanent solution, it does work.

Respondent: user1052478

Solution #13:

Another solution could be.. find the location of composer.phar file in your computer. If composer is installed successfully then it can be found in the installed directory.

Copy that location & instead of composer.phar in the command line, put the entire path there.

It also worked for me!

Respondent: user1052478

Solution #14:

If you go through the documentation, they have mentioned to use php composer.phar
Link: https://getcomposer.org/doc/03-cli.md#update-u

Don’t use php composer.phar
only give composer

Command: composer self-update

It will work.

Respondent: Erielama

Solution #15:

I had the same issue when trying to use php composer install in a local directory on my Apache server for a laravel project I cloned from Github. My problem was I had already setup composer globally on my Ubuntu 18 machine.
Adding sudo instead of php started the install of a whole slew of packages listed in the json.lock file i.e. sudo composer install.

Respondent: Hmerman6006

The answers/resolutions are collected from stackoverflow, are licensed under cc by-sa 2.5 , cc by-sa 3.0 and cc by-sa 4.0 .

Most Popular

To Top
India and Pakistan’s steroid-soaked rhetoric over Kashmir will come back to haunt them both clenbuterol australia bossier man pleads guilty for leadership role in anabolic steriod distribution conspiracy