[Solved] certificate verify failed: unable to get local issuer certificate

I am trying to get data from the web using python. I imported urllib.request package for it but while executing, I get error:

certificate verify failed: unable to get local issuer certificate (_ssl.c:1045)

When I changed the URL to ‘http’ – I am able to get data. But, I believe, this avoids checking SSL certificate.

So I checked on the internet and found one solution:
Run /Applications/Python 3.7/Install Certificates.command

This solved my problem. But I have no knowledge on SSL and the likes. Can you help me understand what it actually did to solve my issue.

If possible, please recommend me any good resource to learn about the security and certificates. I am new to this.


Note: I did go through the link – openssl, python requests error: “certificate verify failed”

My question differs from the one in link because, I want to know what actually happens when I install certifi package or run Install Certificates.command to fix the error. I have a poor understanding of securities.

Solution #1:

For anyone who still wonders on how to fix this, i got mine by installing the “Install Certificates.command

Here is how I did,

Install Certificates.commad location

Just double click on that file wait for it to install and in my case, you will be ready to go

Respondent: Biswajit Paul

Solution #2:

I hit the same issue on OSX, while my code was totally fine on Linux, and you gave the answer in your question!

After inspecting the file you pointed to /Applications/Python 3.7/Install Certificates.command, it turned out that what this command replaces the root certificates of the default Python installation with the ones shipped through the certifi package.

certifi is a set of root certificates. Each SSL certificate relies a chain of trust: you trust one specific certificate because you trust the parent of that certificate, for which you trust the parent, etc. At some point, there is no “parent” and those are “root” certificates. For those, there is no other solution than bundling commonly trusted root certificates (usually big trust companies like eg. “DigiCert”).

You can for instance see the root certificates in your browser security settings (for instance for Firefox->Preference->Privacy and security->view certificates->Authorities).

Coming back to the initial problem, and prior to running the .command file, executing this returns for me an empty list on a clean installation:

import os
import ssl                                        
openssl_dir, openssl_cafile = os.path.split(      
# no content in this folder
# non existent file

This means that there is no default certificate authority for the Python installation on OSX. A possible default is exactly the one provided by the certifi package.

After that, you just can create an SSL context that has the proper default as the following (certifi.where() gives the location of a certificate authority):

import platform
# ...

ssl_context = ssl.SSLContext(ssl.PROTOCOL_TLS)
ssl_context.verify_mode = ssl.CERT_REQUIRED
ssl_context.check_hostname = True

if platform.system().lower() == 'darwin':
    import certifi

and make request to an url from python like this:

import urllib
# previous context
https_handler = urllib.request.HTTPSHandler(context=ssl_context)

opener = urllib.request.build_opener(https_handler)
ret =, timeout=2)
Respondent: Ayyoub

Solution #3:

I would like to provide a reference. I use cmd + space, then type Install Certificates.command, and then press Enter. After a short while, the command line interface pops up to start the installation.

 -- removing any existing file or link
 -- creating symlink to certifi certificate bundle
 -- setting permissions
 -- update complete

Finally, it fixes the errors.

Respondent: Raffi

Solution #4:

This worked in all OS:

import ssl
import certifi

urlopen(request, context=ssl.create_default_context(cafile=certifi.where()))
Respondent: wang

Solution #5:

Paste the following code at the start:

# paste this at the start of code
import ssl 

    _create_unverified_https_context = ssl._create_unverified_context
except AttributeError:
    ssl._create_default_https_context = _create_unverified_https_context
Respondent: Ken

Solution #6:

This page is the top google hit for “certificate verify failed: unable to get local issuer certificate”, so while this doesn’t directly answer the original question, below is a fix for a problem with the same symptom. I ran into this while trying to add TLS to an xmlrpc service. This requires use of the fairly low-level ssl.SSLContext class. The error indicates that a certificate is missing. The fix was to do several things when constructing SSLContext objects:

First, in the client:

def get_client():
    context = ssl.SSLContext(ssl.PROTOCOL_TLS_CLIENT)
    # Load the default certs:

    # Optionally, install the intermediate certs.
    # This _should_ be handled by the server, but
    # maybe helpful in some cases.
    # context.load_verify_locations('path/to/ca_bundle.crt')
    return xmlrpc.client.ServerProxy('', context=context)

In the server, you need to install the intermediate certs in the context:

class SecureXMLRPCServer(socketserver.TCPServer, 
    allow_reuse_address = True

    def __init__(self, addr, certfile, keyfile=None,
            logRequests=True, allow_none=False, encoding=None, 
            bind_and_activate=True, ssl_version=ssl.PROTOCOL_TLSv1_2):
        self.logRequests = logRequests

        # create an SSL context
        self.context = ssl.SSLContext(ssl_version)

        # The server is the correct place to load the intermediate CA certificates:
        self.context.load_cert_chain(certfile=certfile, keyfile=keyfile)

        xmlrpc.server.SimpleXMLRPCDispatcher.__init__(self, allow_none, 
        # call TCPServer constructor
        socketserver.TCPServer.__init__(self, addr, requestHandler, 

        if fcntl is not None and hasattr(fcntl, 'FD_CLOEXEC'):
            flags = fcntl.fcntl(self.fileno(), fcntl.F_GETFD)
            flags |= fcntl.FD_CLOEXEC
            fcntl.fcntl(self.fileno(), fcntl.F_SETFD, flags)

    def get_request(self):
        newsocket, fromaddr = self.socket.accept()
        # create an server-side SSL socket
        sslsocket = self.context.wrap_socket(newsocket, server_side=True)
        return sslsocket, fromaddr
Respondent: Varun Rajkumar

Solution #7:

For those who this problem persists: –
Python 3.6 (some other versions too?) on MacOS comes with its own private copy of OpenSSL. That means the trust certificates in the system are no longer used as defaults by the Python ssl module. To fix that, you need to install a certifi package in your system.

You may try to do it in two ways:

1) Via PIP:

pip install --upgrade certifi

2) If it doesn’t work, try to run a Cerificates.command that comes bundled with Python 3.6 for Mac:

open /Applications/Python 3.6/Install Certificates.command

One way or another, you should now have certificates installed, and Python should be able to connect via HTTPS without any issues.

Hope this helped.

Respondent: RecursivelyIronic

Solution #8:

I had the error with conda on linux. My solution was simple.

conda install -c conda-forge certifi

I had to use the conda forge since the default certifi appears to have problems.

Respondent: Yash Goenka

Solution #9:

For me the problem was that I was setting REQUESTS_CA_BUNDLE in my .bash_profile

export REQUESTS_CA_BUNDLE=/usr/local/etc/openssl/cert.pem

Once I set REQUESTS_CA_BUNDLE to blank (i.e. removed from .bash_profile), requests worked again.


The problem only exhibited when executing python requests via a CLI (Command Line Interface). If I ran requests.get(URL, CERT) it resolved just fine.

Mac OS Catalina (10.15.6).
Pyenv of 3.6.11.
Error message I was getting: [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed: unable to get local issuer certificate (_ssl.c:1056)

This answer elsewhere:

Respondent: netskink

Solution #10:

I recently had this issue while connecting to MongoDB Atlas. I updated to the latest certifi python package and it works now.

(python 3.8, upgraded to certifi 2020.4.5.1, previously certifi version 2019.11.28)

Respondent: Weston Greene

Solution #11:

The cause for this error in my case was that OPENSSLDIR was set to a path which did not contain the actual certificates, possibly caused by some upgrading / reinstallation.

To verify this if this might be the case for you, try running:

openssl s_client -CApath /etc/ssl/certs/ -connect

If you remove the -CApath /etc/ssl/certs/ and get a 20 error code, then this is the likely cause. You can also check what the OPENSSLDIR is set to by running openssl version -a.

Since changing the OPENSSLDIR requires re-compilation, I found the easiest solution to be just creating a symlink in the existing path: ln -s /etc/ssl/certs your-openssldir/certs

Respondent: Joe Walker

Solution #12:

Certifi provides Mozilla’s carefully curated collection of Root Certificates for validating the trustworthiness of SSL certificates while verifying the identity of TLS hosts. It has been extracted from the Requests project.

pip install certifi

Or running the program code below:

# sample script to install or update a set of default Root Certificates
# for the ssl module.  Uses the certificates provided by the certifi package:

import os
import os.path
import ssl
import stat
import subprocess
import sys

STAT_0o775 = ( stat.S_IRUSR | stat.S_IWUSR | stat.S_IXUSR
             | stat.S_IRGRP | stat.S_IWGRP | stat.S_IXGRP
             | stat.S_IROTH |                stat.S_IXOTH )

def main():
    openssl_dir, openssl_cafile = os.path.split(

    print(" -- pip install --upgrade certifi")
        "-E", "-s", "-m", "pip", "install", "--upgrade", "certifi"])

    import certifi

    # change working directory to the default SSL directory
    relpath_to_certifi_cafile = os.path.relpath(certifi.where())
    print(" -- removing any existing file or link")
    except FileNotFoundError:
    print(" -- creating symlink to certifi certificate bundle")
    os.symlink(relpath_to_certifi_cafile, openssl_cafile)
    print(" -- setting permissions")
    os.chmod(openssl_cafile, STAT_0o775)
    print(" -- update complete")

if __name__ == '__main__':

Brew has not run the Install Certificates.command that comes in the Python3 bundle for Mac.

Respondent: Max

The answers/resolutions are collected from stackoverflow, are licensed under cc by-sa 2.5 , cc by-sa 3.0 and cc by-sa 4.0 .

Most Popular

To Top
India and Pakistan’s steroid-soaked rhetoric over Kashmir will come back to haunt them both clenbuterol australia bossier man pleads guilty for leadership role in anabolic steriod distribution conspiracy