Question

[Solved] Bower: ENOGIT Git is not installed or not in the PATH

Git is installed and is in the path.

Platform: Red Hat Enterprise Linux 5.8.

>which git
/usr/local/bin/git

Yet bower can’t find it:

bower angular#1.0.6  ENOGIT git is not installed or not in the PATH

What is the recommended work-around?

Solution #1:

Adding Git to Windows 7/8/8.1 Path

Note: You must have msysgit installed on your machine. Also, the path to my Git installation is “C:Program Files (x86)Git”. Yours might be different. Please check where yours is before continuing.

Open the Windows Environment Variables/Path Window.

  1. Right-click on My Computer -> Properties
  2. Click Advanced System Settings link from the left side column
  3. Click Environment Variables in the bottom of the window
  4. Then under System Variables look for the path variable and click edit
  5. Add the pwd to Git’s binary and cmd at the end of the string like this:

    ;%PROGRAMFILES(x86)%Gitin;%PROGRAMFILES(x86)%Gitcmd
    

Now test it out in PowerShell. Type git and see if it recognizes the command.

This is image showing you how to do so!

Source: Adding Git to Windows 7 Path

Respondent: Eyad Farra

Solution #2:

Just use the Git Bash instead of cmd.

Respondent: Johnathan Douglas

Solution #3:

Run the following command at your node.js command prompt where “<git path>” is the path to your git bin folder:

set PATH=%PATH%;<git path>;

So, like this:

set PATH=%PATH%;C:Program FilesGitin;

Or this: (Notice the (x86) )

set PATH=%PATH%;C:Program Files (x86)Gitin;

This will add git to your path variables. Be sure you type it correctly or you could possibly delete your path vars which would be bad.

Respondent: skinneejoe

Solution #4:

Make sure you installed Git with the second or third option selected from the list. It will penetrate the Git command to cmd by modifying PATH automatically 😉

Enter image description here

Solution #5:

I had the same error in Windows. Adding git to the path fixed the issue.

G:DropboxDevelopmentxampphtdocs.penfolds.gitpenfolds-atg-development>bower install
bower bootstrap#~3.0.0          ENOGIT git is not installed or not in the PATH

G:>PATH
PATH=E:Program FilesWindows Resource KitsTools;

G:DropboxDevelopmentxampphtdocs.penfolds.gitpenfolds-atg-development>set PATH=%PATH%;E:Program FilesGitin;

G:DropboxDevelopmentxampphtdocs.penfolds.gitpenfolds-atg-development>bower install
bower bootstrap#~3.0.0      not-cached git://github.com/twbs/bootstrap.git#~3.0.0
bower bootstrap#~3.0.0         resolve git://github.com/twbs/bootstrap.git#~3.0.0
Respondent: user1491819

Solution #6:

I am also getting the same error and the solution is first to check if the Git is installed or not in the system and if not please install it.

After installation, open Git Bash or Git Shell from Windows and go to your project (same way you go in command prompt using “cd path”). Git Shell is installed by default with Github windows installation.

Then run the same bower install command. It will work as expected.

The below screenshot shows the command using Git Shell
Bower install using Git Shell

Respondent: Rahul Sonone

Solution #7:

On Windows, you can try to set the path at the command prompt:

set PATH=%PATH%;C:Program FilesGitin;
Respondent: GibboK

Solution #8:

When you ran the git install, you probably didn’t choose:

“Use Git from the Windows Command Prompts”

during the installation.

Re-run git install, and choose that option.

Respondent: mtyson

Solution #9:

You are missing the ENVIRONMENT PATH. Follow these steps:

  1. Search for ‘Edit the system environment variables’.
  2. Click on ‘Environment Variables’.
  3. In the ‘System variables’ section, scroll down and click on the variable ‘Path’. Click ‘Edit’.
  4. Append this text to the end of the ‘Variable value’.

;%PROGRAMFILES%Gitin;%PROGRAMFILES%Gitcmd

Respondent: Matt

Solution #10:

I also got the same problem from cmd and resolved using the following steps.

First install the https://msysgit.github.io/ (if not alredy installed).
Then set the Git path as suggested by skinneejoe:

set PATH=%PATH%;C:Program FilesGitin;

Or this (notice the (x86)):

set PATH=%PATH%;C:Program Files (x86)Gitin;
Respondent: Mohit

Solution #11:

In Linux:

if you dont have installed git use:

sudo apt-get update
sudo apt-get install git

with command which git you will know the directory where is and then add in path if it is not in that enviroment variable.

Respondent: David

Solution #12:

I bumped into this problem on a cPanel CentOS 6 linux machine.
The solution for me was to symlink the cPanel git to /usr/local/bin/git

ln -s /usr/local/cpanel/3rdparty/bin/git /usr/local/bin/git
Respondent: adrianthedev

Solution #13:

1.Set the Path of Git in environment variables.
2.From Windows command prompt,
run cd ProjectfolderPath
run the command: bower install

Respondent: Yaaseen

Solution #14:

I solved the problem by install Git Bash from Download Git Bash.

Setting this option 3 when installing the software as shown bellow.

Setting Path variable

Finally select the project folder by right click using Bash as shown below.

enter image description here

and type

npm install

. It works for me.

Respondent: Hassan Rahman

Solution #15:

npm install from git bash did work for me.
After rebooting PC.

Respondent: Wojciechu

Solution #16:

Just use the Git Bash instead of node.js or command prompt

As an Example for installing ReactJS, after opening Git Bash, execute the following command to install react:

bower install --react
Respondent: LOwens1931

Solution #17:

I had the same problem and needed to restart the cmd – and the problem goes away.

Respondent: Yoky

The answers/resolutions are collected from stackoverflow, are licensed under cc by-sa 2.5 , cc by-sa 3.0 and cc by-sa 4.0 .

Most Popular

To Top
India and Pakistan’s steroid-soaked rhetoric over Kashmir will come back to haunt them both clenbuterol australia bossier man pleads guilty for leadership role in anabolic steriod distribution conspiracy