Question

[Solved] Android studio- “SDK tools directory is missing”

When I start the "android studio" program, displayed a window of "downloading components" which says:
  "Android SDK was installed to: C: / Users / user / AppData / Local / android / SDK2
 SDK tools directory is missing "
I can not fix and I need help!!

Solution #1:

The same problem observed on my side while looking for uiautomatorviewer.bat.
After installing Android studio 3.6.2 (at Win10) I was looking for Android SDK Tools section at SDK Manager. Currently, this section is Hidden as Obsolete.
enter image description here
Fix: uncheck Hide Obsolete Packages, then check the mentioned package and install it – C:Users..AppDataLocalAndroidSdk oolsin is created.

Respondent: dxtr80

Solution #2:

“Android SDK was installed to: C: / Users / user / AppData / Local / android / SDK2 SDK tools directory is missing ”
It means the Android SDK requires a folder “tools”, where this SDK was installed. But that “Tools” folder did not get installed. Probably due to low storage.

[SOLUTION] : Uninstall the Android SDK and install it again. This time just make sure that you have ATLEAST 5GB (though 3.2gb would be enough) free space where ever you are going to install this SDK.
Once the installation is complete, just check whether “tools” folder is there or not (At the location where you are installing the SDK)

Respondent: user3517949

Solution #3:

I had this problem on a Mac due to a corporate proxy blocking the installer’s call to the internet. The phase in which the Android Studio installer is supposed to install the SDK did not happen and the install process just went straight to the “SDK tools directory is missing” message. Sadly, there was no message stating that a connection could not be made.

To fix the problem, it was required that I list the path to my corporate PAC file by using Configure -> “Appearance and Behavior” -> System Settings -> HTTP Proxy. I selected “Automatic proxy configuration url:” and entered the correct URL for the PAC file.

Respondent: MalcLear

Solution #4:

Just do the following and it will work fine.

  1. When the error appears instead of clicking on ‘finish’ , click on ‘x’.It will ask to to re initialize. Take the recommended option.
  2. After it reconfiguration it will take back to the main screen. Just go to
    Configure -> Project Defaults -> Project Structure
    and copy paste or browse (appData folder may be hidden) to location
    C: / Users / user / AppData / Local / android / SDK.
  3. Finish and try creating project again. Will work like charm !! 😉

Solution #5:

If your SDK tools directory is missing, maybe you deleted it by accident and there is a easy way to download it and guide android studio to it.

First go to android developer site (https://developer.android.com/studio/index.html), scroll to the bottom of the page and chose your download according to system you have(but don’t download installer version for windows) you need a zip file which contains SDK.

After you download just put it in my documents (MAC or WINDOWS) and then when you open android studio screen will popup for installing SDK (like the time that you got error), don’t click next, go to browse, find that file and press ok. After that go next and it will work like a charm.

That’s it.

Respondent: Beansolder

Solution #6:

This was an issue for me because I already had the SDK installed under a different directory. In order to tell Android Studio to where the SDK is you need to get to the settings, but the “SDK tools directory is missing” dialog always exits the whole program when you click “Finish”. Here’s how I “solved” it:

  1. Delete your ~/.Android* folders (losing all of your settings :/).
  2. Run Android Studio. It will show you a welcome wizard where it tries to download the SDK again (and fails due to my rubbish internet).
  3. Click the X on the wizard window. That will enable you to get to the normal welcome dialog.
  4. Go to Settings->Project Defaults->Project Structure and change the Android SDK location to the correct one.

Deleting the .Android Studio folders may be unnecessary – I never tried pressing the X on the original error dialog – I only tried “Finish” which exits Android Studio. It is possible if you click the X you can get to settings but unfortunately I can’t go back and check now.

Respondent: Timmmm

Solution #7:

I also faced the same problem, problem with me was on my first run I wasn’t connected to Internet properly. After connecting to internet it required some updates to download, and then it ran without any problem

Respondent: ashishdhiman2007

Solution #8:

It was mentioned before but to be clear, It probably is due to your internet connection.

In my case it was that in my job I am behind a proxy, that means I should set a proxy in android studio for it to be able to download all SDK files.

You can set a proxy in the Android Studio Settings under Appearance & Behavior > System Settings > HTTP Proxy as stated here:
https://developer.android.com/studio/intro/studio-config#proxy

Test de proxy (there’s a button for that).
Close Android Studio.
Reopen Android Studio, and it should be able to download all SDK files.

Respondent: dahngeek

Solution #9:

I googled this error and tried all suggestions but nothing to work. My problem is a little bit different. I’m using Ubuntu 16.04 64bit. I was set mount /tmp folder as tmpfs for increasing the performance of applications. My fstab entry was:

tmpfs /tmp tmpfs defaults,noatime,nosuid,nodev,exec,mode=1777,size=1024M 0 0

This is setting /tmp file space to 1G and this is bottleneck for android studio becouse it needs more space in /tmp folder for download SDK files. Now I removed this line and rebooted my computer and everything is working now.

I spend 3 hours for this. I hope help to others.

Respondent: kodmanyagha

Solution #10:

I faced with the same error.

The solution:

Change your proxy settings.
For me I tried all the things like uninstall and system config but it did not work.
When I changed the proxy settings, the list appeared in System Settings->Android SDK->SDK Platforms tab

Still you cannot select the platforms as it is not yet downloaded automatically during installation because of proxy. So just select next and it will download SDK Platforms.

Once this is done, then you can select your platforms and again say ok to download files for that platform.

Now, the last part, once the platform is downloaded successfully then in my case I also had to download NDK.

With the above steps I could successfully create an app.
Happy coding!

Respondent: aniket

Solution #11:

This is INTERNET error
So, Create a SQUID Proxy Server

1. install android studio

2. setup proxy settings in android studio

proxy setting in android studio

3. uninstall android studio and keep user settings

enter image description here

4. install android studio again

5. after finish first setup, then android must detect proxy settings automatically and setup SDK

enter image description here

6. after finish sdk configs, then create your first project

7. confirm proxy settings dialog for first time

enter image description here

Respondent: Eyni Kave

Solution #12:

Try installing it somewhere else, maybe that would solve the problem.
Also, you could try installing it on a USB flash drive.

Respondent: Mike

Solution #13:

Change the SDK directory to C:UsersusernameAppDataLocalAndroidSdk

If you are using the latest android studio you can configure this using
Configure -> Project Defaults -> Project Structure

Respondent: Java Guru

Solution #14:

I had this issue when I was trying to reinstall Android Studio through its wizard. I already had a “tools” folder though.

In my case, while the “tools” directory already existed, it will deliver the “sdk tools directory is missing” error for its subfolders also. Somehow my sdk folder only had a libs subdirectory.

When I pasted in sdk/ant, sdk/apps, sdk/proguard, sdk/qemu, sdk/support, and sdk/templates the wizard was finally happy with this configuration and went to download some more files.

Respondent: Kabliz

Solution #15:

In my case it was installing into an already existing directory. When you choose a directory for the installation. The programm won’t allow you to type in a non-existing directory. So choose the path, get back to the main window and type the new folder name where you want install the SDK, probably feature.

Respondent: Artem Samokhin

Solution #16:

I experienced this error when I was installing Android Studio with too little memory to install everything needed. It didn’t help freeing up memory or installing Android SDK my self. Re-installing Android studio with sufficient memory, made the download start when I first opened up Android Studio.

Respondent: user1728363

Solution #17:

In case you are looking for Android SDK Manager, you can download it here.

It is important to unzip it as C:/Program Files/Android/. Launch the SDK manager by running C:/Program Files/Android/tools/android.bat administrator.

Respondent: Chong Lip Phang

Solution #18:

you can try this before install SDK

brew install java
Respondent: zheng fuchao

Solution #19:

If you are using Windows S.O. make sure it is in the folder:

C:Users**your-user-name**AppDataLocalAndroidSdkplatform-tools

Otherwise, open Android Studio and go to:

Tools> SDK Manager> Android SDK> SDK Tools

Select the Android Platform-Tools and Android SDK Tools checkbox and click Apply. After download check the directory again.

Respondent: Williaan Lopes

Solution #20:

for me, i did this and it worked. just go to C:Users$your username$AppData(which is hidden most likely)Local then at this location try to find this Folder : “Android” if you don’t have it already make one with the exact name and try to open the android studio again.

Respondent: Armin

Solution #21:

when first installing android studio and everything, install sdk to a new file like C:Androidsdk and make sure all the next setup sdk items point to the folder you installed sdk to. It will work fine now… it must have something to do with permissions in the appdata folder is what my guess is

Respondent: Oryanlee

The answers/resolutions are collected from stackoverflow, are licensed under cc by-sa 2.5 , cc by-sa 3.0 and cc by-sa 4.0 .

Most Popular

To Top
India and Pakistan’s steroid-soaked rhetoric over Kashmir will come back to haunt them both clenbuterol australia bossier man pleads guilty for leadership role in anabolic steriod distribution conspiracy