Question

[Solved] Android Studio – No USB devices detected

I tried to play Android Studio 2.0 with my mobile without success, what I did are:

  1. In my mobile, Apps/gear icon/Settings/SYSTEM/{} Developer options/ Android debugging/, enable the Android Debug Bridge(adb) interface (set tick).
  2. After plug in my mobile to my PC with a USB cable, I found A0001 in my Computer folder. Within A0001, I can see the files in my mobile.
  3. In my PC, run Android Studio/bin/studio.exe, “Select Deployment Target” window shows with message “No USB devices or running emulators detected”
  4. I have tried two different USB drivers but got no lucky.
  5. Perhaps I should tell Android Studio where is my USB driver? But, how?
    Can you help?
Enquirer: mark22

||

Solution #1:

I had the same problem too and I managed to resolve it this way.

  1. First, enable debugger mode in your android device.

  2. Go to Device Manager from Start Menu and try to find ADB Interface with an error symbol on it. This generally happens because windows sometimes fail to load all the mobile device drives.

  3. Next, Go to http://adbdriver.com/downloads/ and download the driver installer, unzip and run it.

  4. Now go to Android Studio and you should find that everything is working fine.
    Chill….

Respondent: Saisudhan Sutrave

Solution #2:

same here… but I hope you can avoid this problem the same way I Did.

There is an “universal ADB Driver for all Android Devices”.

Yep… sounds like magic.

Just follow this link.
https://devs-lab.com/usb-adb-drivers-for-all-android-devices.html

Fun fact there is no “Step 5” in that article so I’ll give you.

you have to enable “USB Depuration” from “Developer Options” connect your cellphone to computer as a “MTP storage” , after windows detected your cellphone as a “Portable Device” Execute ADBDriverInstaller.exe (that downloaded from devs-lab)

check the device list and your cellphone will say “Driver incorrectly“, select your cellphone and press install.

Step 6: Once the process is completed, you’ll see something like the image that appears there (in the link).

I hope that somebody else work this

Respondent: Israel

Solution #3:

  1. Go to Run > Edit Configurations...

  2. Under Deployment Target Options select Show Device Chooser
    Dialog
    from the drop-down-list

See picture for reference
enter image description here

Respondent: T.S

Solution #4:

After struggling with this problem for a while, I found that there are certain cables that can only charge your phone, and even though they seem to be working, they do not allow your phone to be used as a “Media Device” and therefore Android Studio does not detect it.

Respondent: Jacobo Koenig

Solution #5:

Go to

Tools | Android | Enable ADB Integration

Make sure it’s enabled. When I upgraded to 2.X it was for some reason disabled for me and it took me hours to find it.

Respondent: Janne Oksanen

Solution #6:

I just cannot beleive why it is so difficult! let me try again and please check my steps again:
I installed Android Studio 2.0, then run Computer/OS(C:)/……/Android Studio/bin/studio.exe.
The Android Studio window appeared in my working area Computer/OS2(J:)/Users/MyAccount/Desktop/.
I connected my mobile with my computer, Cpmputer/A0001/ appeared, from it, I can see the files in my mobile.
I clicked the run icon in the Android Studio window, a “Select Deployment Target” window apeared with message “No USB devices or running emulators detected”.
(I got two USB ports and tried both but got the same result.)

Respondent: mark22

Solution #7:

Finally found the solution : )

 1. Install device’s required driver. (for me it was motorola device
    manager) 
 2. Download Google Usb Driver from SDK Manager 
 3. Open your phone's setting->developer options and turn on USB debugging. 
 4. connect your device to computer
 5. Go to Device Manager from Start Menu and try to find if there is ADB Interface with an error symbol on it. 
 5.1. If yes, then right click on the ADB interface->Update driver
    software->Browse my computer for driver software-> Let me pick from
    a list of device drivers on my computer->Select Motorola ADB interface 
 5.2. Now one confirmation will pop up in your mobile, accept it
 5.3. Now you should see no error mark beside the ADB interface in your
    device manager
Respondent: Junaed

Solution #8:

Perhaps your mobile manufacturer does not provide the proper driver.
Go to Device MAnager and look for: Android Composite ADB Interface. If it’s there, the driver is properly installed. If not… You and I are on the same “wagon”…
I tell you: Acer? Never again.

Respondent: Pietrov

Solution #9:

USB debugging somehow got turned off under developer options on my Samsung. Turned it back on and it worked, but only by clicking on “debug app” instead of on “run app”.

Respondent: John Ashmore

Solution #10:

There are 3 steps to set up your phone for debugging:

1) Change your phone to developer’s mode by going to Settings, About Phone, Software Info, Android Version – tap at least 7 times on the Build Number text. You will get a message saying you are now a Developer.

2) Enable USB Debugging in Settings – Developer Options. Make sure you are not connected to your USB port to see the USB Debugging option enabled, otherwise it will be disabled.

After you plug in your USB, swipe at the top of your screen, you will see USB Debugging on.

3) Make sure USB connection is set to Photo Transfer (or MTP – Transfer photos and videos). After you plug in your USB, swipe at the top of your screen, and you will see Tap to change USB options on the menu. Tap it, and select Photo Transfer option.

enter image description here

enter image description here

Respondent: live-love

Solution #11:

Few ways to resolve this problem.

Case 1: Install PdaNet+ in your system. (worked for me).

Case 2: Enable the USB debugging option in your mobile. Setting > developer > Check “USB Debugging”.

Case 3: Change from MTP to PTP.(sometimes vise versa works).

Respondent: meyasir

Solution #12:

First, try to revoke the usb sessions in the developer options, then try downloading an oem usb driver
If then doesn’t help you can try opening the device manager on windows, right click on your phone, select uninstall. This worked for me if I had the same issue.

Respondent: 770grappenmaker

Solution #13:

Question is Your development sdk no mobile version android sdk Platform.
For example, my android phone system is 6.0, i need download sdk Platform 6.0.enter image description here

Respondent: VenRen

The answers/resolutions are collected from stackoverflow, are licensed under cc by-sa 2.5 , cc by-sa 3.0 and cc by-sa 4.0 .

Most Popular

To Top
India and Pakistan’s steroid-soaked rhetoric over Kashmir will come back to haunt them both clenbuterol australia bossier man pleads guilty for leadership role in anabolic steriod distribution conspiracy