Question

[Solved] Android emulator not starting at all

Today I tried to launch my Android app from within eclipse but nothing happened. Everything worked fine yesterday. I tried a few things like adb kill-server, adb-start-server. At some point I got the “user data image is used by another emulator” error, so I went about deleting the .lock folders in the avd image but to no avail.

I created a new avd and the emulator doesnt even start with this image. I tried to start it with

emulator -avd avdname

->nothing. No error. emulator.exe is running in Taskmanager.

Windows 7
Android SDK Tools, revision 7

Update: Now I know when I get the error

emulator: ERROR: the user data image is used by another emulator. aborting

it’s when I try to run the application again after the emulator.exe is already dangling in Taksmanager.

Update: waited for 20mins. emulator.exe is just sitting there with 00:00:00 cpu time.

Enquirer: boston

||

Solution #1:

When you say, “Everything worked fine yesterday”, you should first ask yourself what you have changed since; have you installed anything that could interfere with the emulator?

Personally, I would download a fresh copy of the Android SDK, remove the reference to the currently installed version from your PATH, and add the new one.

I should think that would solve your issue (at least, being able to start an AVD that is).

One more thing to note is that the AVD can sometimes be quite slow to startup. On one of my machines, it has taken up to 7 minutes to boot up. So try emulator -avd avdname, then go make a coffee and see if it works when you return 🙂

Good luck!

Respondent: boston

Solution #2:

I had a smiliar problem in MacOS Sierra 10.12.4 and Android Studio 2.3.1.

I tried everything, I uninstalled and reinstalled Android Studio, rebooted the computer, cleared the .android folder and created a new avd image. Nothing helped me, but finally I ran this command (See more in Android Documentation):

emulator -partition-size 512 -avd avd_name 

And I received this error:

emulator: WARNING: encryption is off
Hax is enabled
Hax ram_size 0x40000000
HAX is working and emulator runs in fast virt mode.
Failed to sync vcpu reg
Failed to sync vcpu reg
Failed to sync vcpu reg
Failed to sync HAX vcpu contextInternal error: Initial hax sync failed 

With that, I discovered that my solution was to stop Docker-Machine, and, like magic, it solved the problem.

Respondent: Jimmy

Solution #3:

I had this issued after upgrading Android Studio.

  • Open the AVD manager
  • Open the context menu for your image. (right click)
  • Select Cold Boot Now

ScreenShot

Respondent: carolnogueira

Solution #4:

Well, I came across the same issue, I spent several hours uninstalling, re-installing, the DSK tools, and Eclipse individually, and also messed with the Bundle and the VM was simply not launching. Previous to that, I created a virtual machine, and worked fine for a day. What I did, was simply erased the .android folder from the C:UsersUSER folder and created a new virtual machine. It worked without any problems since then.

Respondent: Steven Spungin

Solution #5:

Or : Window ->AVD Manager -> pick your virtual device ->Edit-> Snapshot(make sure is disabled) ->Edit AVD (try again, if still not working , then try to launch the emulator directly from AVD Manager -> Start).

Respondent: user1908637

Solution #6:

enabling software graphic support instead of hardware worked for me.

Respondent: user1207965

Solution #7:

I tried the ‘kill adb-server and start adb-server’ approach but it didn’t work. I deleted my AVD and created a new AVD with the same configuration, and it worked. Hardly took 30 seconds.

Respondent: stream28

Solution #8:

In linux:

Go to to your home directory

$cd ~/.android/avd 
$ls
$NexusS.avd/  NexusS.ini
$rm *.ini
$rm -rf NexusS.avd/      (don't use sudo and use TAB to bring in Nexus avd directory)

Restart eclipse and create new AVDs

Windows users should do the same in their user directory i.e C:/Users/FooBar/android/avd

Respondent: RohitD

Solution #9:

I faced with similar issue and something that worked for is, run the android virtual device manager and when you launch your AVD, remove the check start from the last snapshot.

I did this and it worked for me.

Respondent: HimalayanCoder

Solution #10:

most often deleting .android folder in user make the sense but

unbeleivable ,some of these types of problem may due to display drivers.. try switching drivers to dedicated graphics or reinstall main driver.. …

Respondent: Ray

Solution #11:

firstly get name of your SDK’s with

emulator -list-avds

Then you run command emulator -partition-size 512 -avd avd_name as carolnogueira recomended

for me it was not enought disk space, and after clear some unnecessary files, it worked fine

Respondent: Binod Rokka

Solution #12:

After updating to windows 10 my graphics drivers started acting weird.

Disable the "Use Host GPU"

enabled the emulator to start for me

Respondent: Ali Ă–zyer

Solution #13:

For me the problem was that I ran android studio from terminal, with root.

When I opened studio normally from the applications folder and created a new AVD(the root one was not present), the AVD started.

Respondent: Ashitakalax

Solution #14:

I got it to work by doing the following:

  1. Right click on emulator in list.
  2. Select Wipe Data
Respondent: tonisives

Solution #15:

I faced a similar issue because there was not enough space in disk. So I deleted unwanted stuff and it worked for me.

Respondent: Henning Hall

Solution #16:

May be you have created a new device that causing problem to start AVD. Delete that device and all will work fine.

Respondent: Asbar Ali

Solution #17:

It’s not working sometimes when your disk free space ran out. Check that as well. My issue was lack of empty disk space.

Respondent: Shivam Dawar

Solution #18:

Faced a similar issue, mine was due to a space issue as the emulator wasn’t able to launch.

Solution – Cleaned up system space and was able to launch the emulator

Respondent: ireshan pathirana

The answers/resolutions are collected from stackoverflow, are licensed under cc by-sa 2.5 , cc by-sa 3.0 and cc by-sa 4.0 .

Most Popular

To Top
India and Pakistan’s steroid-soaked rhetoric over Kashmir will come back to haunt them both clenbuterol australia bossier man pleads guilty for leadership role in anabolic steriod distribution conspiracy