Question

[Solved] ‘adb’ is not recognized as an internal or external command, operable program or batch file

I am trying to run google map v2 on emulator, I am following this tutorial.
When I was trying to install required apk file on emulator, I am getting below error.

I tried to solve this using this tutorial.Followed all steps, added the path to paltform-tools to environment path. Also after modifying the PATH variable started a new CommandPrompt window.

But getting the same error. I need to check my google map application on emulator.
Kindly suggest me.

'adb' is not recognized as an internal or external command,
operable program or batch file.

enter image description here

Solution #1:

Set the path of adb into System Variables. You can find adb in “ADT Bundle/sdk/platform-tools” Set the path and restart the cmd n then try again.

Or

You can also goto the dir where adb.exe is located and do the same thing if you don’t wanna set the PATH.

If you wanna see all the paths, just do

echo %PATH%
Respondent: Jatin Malwal

Solution #2:

From Android Studio 1.3, the ADB location is at:

C:UsersUSERNAMEAppDataLocalAndroidsdkplatform-tools.

Now add this location to the end of PATH of environment variables. Eg:

;C:UsersUSERNAMEAppDataLocalAndroidsdkplatform-tools
Respondent: Vamsi Tallapudi

Solution #3:

If you want to use it every time add the path of adb to your system variables:
enter to cmd (command prompt) and write the following:

echo %PATH%

this command will show you what it was before you will add adb path

setx PATH "%PATH%;C:Program Filesandroid-sdk-windowsplatform-tools"

be careful the path that you want to add if it contains double quote

after you restart your cmd rewrite:

echo %PATH%

you will find that the path is added

PS: if you just want to add the path to cmd just to this session you can use:

set PATH=%PATH%;C:Program Filesandroid-sdk-windowsplatform-tools
Respondent: Chris Sim

Solution #4:

I did this on Windows 7, by going to:

Start > Control Panel > System > Advanced System Settings > Environment Variables…

In this Environment Variables window, in the User variables for (your-username) highlight Path and click Edit…

You then need to append a ; if there isn’t already one at the end of the Variable value field, and then append C:Users<your-username>AppDataLocalAndroidsdkplatform-tools; to that same field.

Then click the three OK buttons to get out.

If you already have a Command Prompt window open, close it then re-open and the adb devices command should then work.

Solution #5:

In Windows 10,

  1. Add User Variable PATH: %USERPROFILE%AppDataLocalAndroidsdkplatform-tools.
  2. Restart cmd (if any open).
  3. adb devices, it should list, if it does, you are all set.

That’s it!

Respondent: m9m9m

Solution #6:

Follow path of you platform tools folder in android setup folder where you will found adb.exe

D:SoftwareAndroidAndroidandroid-sdkplatform-tools

Check the screenshot for details

enter image description here

Respondent: Vaibhav Agarwal

Solution #7:

Add your path into environment variable “PATH” where you installed your sdk with below:

Sdkplatform-tools

You can in image below for example:

enter image description here

and reopen your command prompt to see changes.

Respondent: gauravbhai daxini

Solution #8:

adb command can be under the new path below-
C:UsersUSERNAMEAppDataLocalAndroidsdkplatform-tools
for new versions of Android studio.
I found in this location for me.

Respondent: Amit Ray

Solution #9:

If your OS is Windows, then it is very simple.
When you install Android Studio, adb.exe is located in the following folder:

C:Users**your-user-name**AppDataLocalAndroidSdkplatform-tools

Copy the path and paste in your environment variables.

Open your terminal and type: adb it’s done!

Respondent: Williaan Lopes

Solution #10:

enter image description here

For environment variable, we have to need to follow some steps.

Respondent: Parveen Chauhan

Solution #11:

just open Android studio and press “Tools” on Top navigation bar

tools->SDK Manager

Where you can get SDK location

Open SDK folder -> platform-tools

Respondent: Pullat Junaid

Solution #12:

1st: goto the drive where your eclipse reside and goto sdk and platform tool in my case C:adt-bundle-windows-x86_64-20140702sdkplatform-tools

2nd:copy that address for ease of access

enter image description here

3:open command prompt win+r and type cmd hit enter

4:paste the address in cmd and hit enter thats all

enter image description here

Respondent: Adiii

Solution #13:

Based on Vamsi Tallapudis earlier answer I came up with this dynamic path:

%LOCALAPPDATA%/Androidsdkplatform-tools

It’s using a Windows Environment Variables. I find this solution to be both elegant and easy and would therefor like to share it.

Respondent: Tim

Solution #14:

I had same problem when I define PATH below

C:Program Files (x86)Javajre1.8.0_45in;C:devsdkandroidplatform-tools

and the problem solved when I bring adb root at first.

C:devsdkandroidplatform-tools;C:Program Files (x86)Javajre1.8.0_45in
Respondent: user5903234

Solution #15:

This is where I found it:

C:Users<USER>AppDataLocalAndroidsdkplatform-tools

I had to put the complete path into the file explorer. I couldn’t just click down to it because the directories are hidden.

I found this path listed in Android studio:

Tools > Android > SDK Manager > SDK Tools

Respondent: user984003

Solution #16:

This answer assumes that the PATH has been correctly set as described in the other answers

If you’re on Windows 10 and dont have Admin rights then right click on the CMD, powershell … program and select run as administrator. Then try adb [command]

Respondent: beaumondo

Solution #17:

On Window, sometimes I feel hard to click through many steps to find platform-tools and open Environment Variables Prompt, so the below steps maybe help

Step 1. Open cmd as Administrator

Step 2. File platform-tools path

cd C:
dir /s adb.exe

Step 3: Edit Path in Edit Enviroment Variables Prompt

rundll32 sysdm.cpl,EditEnvironmentVariables

more, the command to open environment variables can not remember, so I often make an alias for it (eg: editenv), if you need to work with environment variables multiple time, you can use a permanent doskey to make alias

Step 4: Restart cmd

Respondent: Linh

Solution #18:

First select drive that is where Android sdk folder is there. Then you Follow the below steps

cd DriveName:/ or Ex : cd c:/ Press ‘Enter’

then you will give the path that is adb console path is there in a platform-tools folder
so
cd Root Folder/inner root folder if there/Platform-tools Press ‘Enter’ then it selects the adb directory.

Respondent: Venkat

Solution #19:

In my case it was:

C:Program Files (x86)Androidandroid-sdkplatform-tools
Respondent: Dorad

Solution #20:

If you didn’t set a path for ADB, you can run .adb instead of adb at sdk/platformtools.

Respondent: Mohammad Meshkani

Solution #21:

I recommand you using PowerShell

Set Android Studio Terminal to PowerShell:

Settings > Tools > Terminal > Shell path = pwsh.exe (instead of cmd.exe)

Open Terminal on Android Studio

PowerShell 7.0.1
Copyright (c) Microsoft Corporation. All rights reserved.

https://aka.ms/powershell
Type 'help' to get help.

PS >

Test the path for adb.exe

# `pikachu` should be replace your username
PS > test-path "C:UserspikachuAppDataLocalAndroidsdkplatform-tools"
True

Open your powershell profile file in your text editor

PS > notepad $profile

add below line, save and exit

# `pikachu` should be replaced with your username
$env:PATH+="C:UserspikachuAppDataLocalAndroidsdkplatform-tools"

re-open Terminal and try adb

PS > adb
Android Debug Bridge version 1.0.41
Version 30.0.1-6435776
Installed as C:UsershdformatAppDataLocalAndroidsdkplatform-toolsadb.exe

global options:
 -a         listen on all network interfaces, not just localhost
 -d         use USB device (error if multiple devices connected)
 -e         use TCP/IP device (error if multiple TCP/IP devices available)
 -s SERIAL  use device with given serial (overrides $ANDROID_SERIAL)
 -t ID      use device with given transport id
 -H         name of adb server host [default=localhost]
 -P         port of adb server [default=5037]

Respondent: user1960422

Solution #22:

For those using macOS, this osxdaily.com article shows several ways to add adb to the $PATH.

Here’s the one I prefer:

  1. Add a file named adb to /etc/paths.d/ folder that just contains the path to adb’s location: /Users/YourUserName/Library/Android/sdk/platform-tools/

    In a Terminal window, sudo vim /etc/paths.d/adb
    -> enter the path and save the file.

  2. Close/re-open Terminal in order for it to see the change.

Respondent: jk7

Solution #23:

It seems that Avast antivirus detects adb.exe as a virus and adds it to it chest

Respondent: Fuse Gamer

Solution #24:

You could just drag the adb.exe on to the command prompt from sdk/platformtools and leave a space and type the command you want: like logcat.

It looks like this for me:

C:adt-bundle-windows-x86-20130917adt-bundle-windows-x86-20130917sdkplatform-tools.exe logcat

and hit enter.

Respondent: krishnaraj916

Solution #25:

for me I was still getting

'adb' is not recognized as an internal or external command,
operable program or batch file. 

even after setting the path in environment variables…… restarting Android Studio solved the problem.

Respondent: Mohammed Fathi

The answers/resolutions are collected from stackoverflow, are licensed under cc by-sa 2.5 , cc by-sa 3.0 and cc by-sa 4.0 .

Most Popular

To Top
India and Pakistan’s steroid-soaked rhetoric over Kashmir will come back to haunt them both clenbuterol australia bossier man pleads guilty for leadership role in anabolic steriod distribution conspiracy