On fresh Vagrant VM using box bento/centos-7 the following commands corrupt my pip installation:

yum update
yum install epel-release -y
yum install python-pip -y
/usr/bin/pip2 install --upgrade pip setuptools pyOpenSSL psycopg2-binary lxml

This fails at the end with

  Downloading https://files.pythonhosted.org/packages/84/48/5c99d8770fd0a9eb0f82654c3294aad6d0ba9f8600638c2e2ad74f2c5d52/setuptools-52.0.0.tar.gz (2.1MB)
    100% |????????????????????????????????| 2.1MB 821kB/s
    Complete output from command python setup.py egg_info:
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "setuptools/__init__.py", line 16, in <module>
        import setuptools.version
      File "setuptools/version.py", line 1, in <module>
        import pkg_resources
      File "pkg_resources/__init__.py", line 1367
        raise SyntaxError(e) from e
                                ^
    SyntaxError: invalid syntax

    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-GZrC3W/setuptools/
You are using pip version 8.1.2, however version 21.0 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.

If I then upgrade Pip I notice that my Python is broken. After that all pip commands end with SyntaxError

[[email protected] ~]# pip install --upgrade pip
Collecting pip
  Using cached https://files.pythonhosted.org/packages/9e/24/bc928987f35dd0167f21b13a1777c21b9c5917c9894cff93f1c1a6cb8f3b/pip-21.0.tar.gz
Installing collected packages: pip
  Found existing installation: pip 8.1.2
    Uninstalling pip-8.1.2:
      Successfully uninstalled pip-8.1.2
  Running setup.py install for pip ... done
Successfully installed pip-21.0
[[email protected] ~]# /usr/bin/pip2 install --upgrade pip setuptools pyOpenSSL psycopg2-binary lxml
Traceback (most recent call last):
  File "/usr/bin/pip2", line 9, in <module>
    load_entry_point('pip==21.0', 'console_scripts', 'pip2')()
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 378, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2566, in load_entry_point
    return ep.load()
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2260, in load
    entry = __import__(self.module_name, globals(),globals(), ['__name__'])
  File "/usr/lib/python2.7/site-packages/pip/_internal/cli/main.py", line 60
    sys.stderr.write(f"ERROR: {exc}")
                                   ^
SyntaxError: invalid syntax

Why is this? Is this a known issue with Python? How do I fix this?

BTW, CentOS 7 is a given, we cannot upgrade to CentOS 8 at this point. Also, we are using Ansible so using virtualenv I think for target nodes is recommended against by the Ansible community.

We can install Python 3 of course on target nodes but not all Ansible code is available for combination Python 3 with CentOS 7.

Can we use Pip 20? We would like to upgrade to the most recent version of Pip that still works and I think that is Pip 20. How do I prevent upgrade to Pip 21?

You can get an older version (2.7) of get-pip.py

curl https://bootstrap.pypa.io/pip/2.7/get-pip.py --output get-pip.py

In my opinion, you should create a python2 virtualenv and install your python2 package in it, as well as pip2. For example, when I installed cuckoo sandbox, I did it like this:

virtualenv --python=python2 cuckoo/   # make your virtualenv folder with python2
cd cuckoo
source bin/activate
curl https://bootstrap.pypa.io/pip/2.7/get-pip.py --output get-pip.py   # get pip for python2
python2 get-pip.py        # install pip in your virtualenv
pip install cuckoo       # install your python2 package

Hope it will help.

This problem has to do with the fact that Python 2.7 reached end of its life and that the PIP community dropped support for it this month.

PIP displays deprecation notices such as

DEPRECATION: Python 2.7 reached the end of its life on January 1st,
2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021.
More details about Python 2 support in pip can be found at
https://pip.pypa.io/en/latest/development/release-process/#python-2-support
pip 21.0 will remove support for this functionality.

To fix this and continue with unsupported Python 2.7 you should not upgrade to the latest pip version but to a version < 21.

pip install --upgrade "pip < 21.0"

As PIP dropped support for Python 2.7 in result we are facing the above mentioned issue, following are the commands which actually worked for me on Ubuntu.

sudo apt-get remove --purge python-pip
sudo apt-get autoremove
sudo rm -f /usr/local/bin/pip
sudo easy_install pip==20.3.4
pip --version

Output: pip 20.3.4

Same can be achieved for CentOS by changing package manager name.

Update: Please use following command to install the pip on python2.7

curl  https://bootstrap.pypa.io/pip/2.7/get-pip.py -o get-pip.py
python get-pip.py

Enjoy it!

This helped me (Ubuntu 16.04)

In general I removed completely pip and pip3 like:

whereis pip
sudo rm -f <results from whereis pip
whereis pip3
sudo rm -f <results from whereis pip3

Search pip and remove files and directories. In my case it was:

sudo rm -fr ~/.local/bin/pip3.5
sudo rm -fr ~/.local/bin/pip3
sudo rm -fr ~/.local/lib/python3.5/site-packages/pip*
sudo rm -rf ~/.cache/pip/
sudo rm -rf  /usr/lib/python2.7/dist-packages/pip*
sudo rm -rf  /usr/lib/python3/dist-packages/pip*

Then I installed pip3 once again:

Python 3.5

wget https://bootstrap.pypa.io/pip/3.5/get-pip.py

Python 3.6

wget https://bootstrap.pypa.io/get-pip.py
python3 get-pip.py --ignore-installed

Its version conflict issue. first check python –version, below steps for python version 2.7

  1. curl https://bootstrap.pypa.io/2.7/get-pip.py -o get-pip.py
  2. python get-pip.py
  3. install virtual env: python -m pip install –user virtualenv
  4. create venv: python -m virtualenv env
  5. activate venv: source env/bin/activate

When you tried to upgrade pip it was upgraded to version 21 and as written in the link: Python2-support

pip 20.3 was the last version of pip that supported Python 2. Bugs reported with pip which only occur on Python 2.7 will likely be closed as “won’t fix” issues by pip’s maintainers.

So now you first need to remove the current pip installed, which you can do from
Centos 7:

yum remove python2-pip

Now we will install pip again

yum install python2-pip -y

Now we will upgrade pip to the supported version

pip install --upgrade pip==20.3.4

Now pip command will work fine

pip -V

I’m reporting my solution because it worked for me on MacOS (not on Linux, which these other solutions were for). Hopefully this will help someone in case they have a problem similar on Mac. I’m running MacOS 11.4. PIP got broken on my system somehow. My global system is supposed to be using Python3 but I was getting the error message:

 Traceback (most recent call last):
  File "/usr/local/bin/pip", line 11, in <module>
    load_entry_point('pip==21.0.1', 'console_scripts', 'pip')()
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources/__init__.py", line 489, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources/__init__.py", line 2843, in load_entry_point
    return ep.load()
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources/__init__.py", line 2434, in load
    return self.resolve()
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources/__init__.py", line 2440, in resolve
    module = __import__(self.module_name, fromlist=['__name__'], level=0)
  File "/Library/Python/2.7/site-packages/pip-21.0.1-py2.7.egg/pip/_internal/cli/main.py", line 60
    sys.stderr.write(f"ERROR: {exc}")
                                   ^
SyntaxError: invalid syntax

My solution was running this:

curl https://bootstrap.pypa.io/get-pip.py -o get-pip.py
python3 get-pip.py

Now PIP is working again on my system.

If this logic is used in a (e.g.) Github Actions matrix of different Python versions, the following bash snippet will determine if pip should be updated before pip 21.0 or not. For instance, Python 3.5 should not update beyond pip 21.0, but Python 3.6 can use more recent versions.

use_pip_lt_21=`python -c "import sys; print(sys.version_info[:2] < (3, 6))"`
if [ $use_pip_lt_21 = "True" ]; then
  pip="pip < 21.0"
else
  pip="pip"
fi
pip install --disable-pip-version-check --upgrade "$pip"

Environment

Ubuntu 16.04 LTS 32-bit.

Ubuntu 16.04.7 LTS (GNU/Linux 4.4.0-209-generic i686)

Python 3.5

I was getting the error running these commands:

$ sudo python3 -m venv /opt/certbot/
$ sudo /opt/certbot/bin/pip install --upgrade pip
$ sudo /opt/certbot/bin/pip install certbot

Traceback (most recent call last): File “/opt/certbot/bin/pip”, line
7, in
from pip._internal.cli.main import main File “/opt/certbot/lib/python3.5/site-packages/pip/_internal/cli/main.py”,
line 58
sys.stderr.write(f”ERROR: {exc}”)
^ SyntaxError: invalid syntax

The python3 is just a symlink to python3.5:

/usr/bin/python3 -> python3.5

Python 3.9

Another error is thrown:

$ sudo python3.9 -m venv /opt/certbot/

Error: Command ‘[‘/opt/certbot/bin/python3.9’, ‘-Im’, ‘ensurepip’,
‘–upgrade’, ‘–default-pip’]’ returned non-zero exit status 1.

Solution: Python 3.6

These commands solved the problem for me:

$ sudo python3.6 -m venv /opt/certbot/
$ sudo /opt/certbot/bin/pip install --upgrade pip
$ sudo /opt/certbot/bin/pip install certbot

these commands solved for me on ubuntu 20.04 LTS:

$ sudo apt update
$ sudo apt upgrade
$ sudo add-apt-repository universe
$ sudo apt install python2
$ curl https://bootstrap.pypa.io/2.7/get-pip.py | sudo python
$$ pip --version

summarized from https://linuxhint.com/install_python_pip_tool_ubuntu/ and https://unix.stackexchange.com/a/631283 by editin 5th command

remove the pip and reinstall it, on ubantu16.04

sudo apt-get remove --purge python-pip
sudo apt-get autoremove
rm -r /home/xxx/.local/bin/pip
rm -r /usr/local/bin/pip
sudo apt update
curl https://bootstrap.pypa.io/2.7/get-pip.py | sudo python
sudo ln /usr/local/bin/pip /home/xxx/.local/bin/pip