I’m trying to install Pillow on Ubuntu 14.04 using this command:

pip install Pillow

but the installation fails with this error:

ValueError: --enable-jpeg requested but jpeg not found, aborting.

The problem was that the package libjpeg-dev was not installed. To solve the problem you should do this:

sudo apt-get install libjpeg-dev

Make sure Python-development packages are installed, if not then install it using the following commands :

For Ubuntu

sudo apt-get install python3-dev python3-setuptools

For Fedora

sudo dnf install python-devel

After installing the development packages install the following :

For Ubuntu

sudo apt-get install libtiff5-dev libjpeg8-dev zlib1g-dev \
libfreetype6-dev liblcms2-dev libwebp-dev tcl8.6-dev tk8.6-dev python-tk

For Fedora

sudo dnf install libtiff-devel libjpeg-devel libzip-devel freetype-devel \
lcms2-devel libwebp-devel tcl-devel tk-devel

You have to install the missing dependencies and libraries that Pillow requires for it to work. Find the dependencies here

This are the current dependancies/libraries for Ubuntu 14.04 for Pilllow 3.0.0+. Install them by running the command below

sudo apt-get install libtiff5-dev libjpeg8-dev zlib1g-dev \
libfreetype6-dev liblcms2-dev libwebp-dev tcl8.6-dev tk8.6-dev python-tk

There may be a problem where pip is relying on a cached version of the dependencies, and clearing the cache can sometimes solve the problem. Just type

$ rm -rf ~/.cache/pip

Source: github issue

You need to follow this tutorial Install pillow doc.

If you had installed, just uninstall and reinstall again:

$ pip uninstall pillow
$ pip install pillow --no-cache-dir