libxml2.2.dylib reference in python program

A python library that I’m using uses libxml2.2.dylib. I’m getting this error message:

Reason:

Incompatible library version: etree.so requires version 12.0.0 or later, but libxml2.2.dylib provides version 10.0.0

My system’s version of libxml2.2.dylib is older and is in /usr/lib/. I downloaded the newest version of libxml2.2.dylib using homebrew, and that is in /usr/local/Cellar/libxml2/2.9.1/lib/.

I would like my Python application to use that version instead of the one the system uses.

Is this a matter of adding the homebrew folder to the path?

Enquirer: Dash

||

Solution #1:

Try to follow the instructions here to build lxml with static dependencies. This way you don’t have to worry about which version of libxml2 or libxslt it is linked against.

It could boil down to

STATIC_DEPS=true pip install -U lxml
Respondent: oDDsKooL

The answers/resolutions are collected from stackoverflow, are licensed under cc by-sa 2.5 , cc by-sa 3.0 and cc by-sa 4.0 .

Leave a Reply

Your email address will not be published.