install_requires based on python version

Each Answer to this Q is separated by one/two green lines.

I have a module that works both on python 2 and python 3. In Python<3.2 I would like to install a specific package as a dependency. For Python>=3.2.

Something like:

    "threadpool >= 1.2.7 if python_version < 3.2.0",

How can one make that?

Use environment markers:

    'threadpool >= 1.2.7; python_version < "3.2.0"',

Setuptools specific usage is detailed in their documentation. The syntax shown above requires setuptools v36.2+ (change log).

This has been discussed here, it would appear the recommend way is to test for the Python version inside your using sys.version_info;

import sys

if sys.version_info >= (3,2):
    install_requires = ["threadpool >= 1.2.7"]
    install_requires = ["threadpool >= 1.2.3"]

setup(..., install_requires=install_requires)

The answers/resolutions are collected from stackoverflow, are licensed under cc by-sa 2.5 , cc by-sa 3.0 and cc by-sa 4.0 .