Each Answer to this Q is separated by one/two green lines.
I have checked my
pip version and got the following output:
Requirement already up-to-date: pip in ./anaconda3/envs/runlee_python3/lib/python3.8/site-packages (20.1)
I have a specific situation in which I have to use version 1.15 of Tensorflow, but when I try to install it, it seems like it can‘t find this specific version.
pip install tensorflow==1.15 ERROR: Could not find a version that satisfies the requirement tensorflow==1.15 (from versions: 2.2.0rc1, 2.2.0rc2, 2.2.0rc3) ERROR: No matching distribution found for tensorflow==1.15
I can also not find version 1.15 when listing all available options.
What am I missing?
You are using python 3.8, which was not officially supported when tensorflow was at version 1.15. You can also check on pypi, there are no files available for cp38, even for 2.10 Onle the versions listed by your command have a cp38 whl file available, see here
Since you have conda, simply create a virtual env with the required version
conda create -n tf python=3.7
then install tensorflow in this env
You must be using python <=3.7 to install Tensorflow 1.15. See the pypi release page. Assuming you are and you still get this issue, upgrading from
pip-21.0.1 fixed it for me. Try upgrading pip.